axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Craig M" <cmarge...@cox.net>
Subject Re: tomcat shutdown problem with axis webapp
Date Sat, 26 Jun 2004 11:05:53 GMT
Nobody has any input on this issue?

----- Original Message ----- 
From: "Craig Margenau" <cmargenau@cox.net>
To: <axis-user@ws.apache.org>
Sent: Thursday, June 24, 2004 9:42 AM
Subject: tomcat shutdown problem with axis webapp


> Shutting down tomcat with the axis webapp installed causes tomcat to not
shutdown fully, leaving many java threads runing that require issuing a
'kill -9 ...' in order to restart tomcat.
>
> New installation of tomcat 4.1.30, new installation of axis 1.1 final
release.  No conf changes, just copied the axis subdir under webapps to
tomcats webapps dir and restarted tomcat.  $JAVA_HOME set to use jdk
1.3.1_09.
>
> I've read a few similar posts but have not seen any solution for this
problem yet.  It's driving me crazy, so I'm beginning to wonder if it could
be Linux distro related.  We have an older Redhat 7.1 distro at work we
develop on.
>
>
> $ more /proc/version
> Linux version 2.4.7-10smp (bhcompile@stripples.devel.redhat.com) (gcc
version 2.96 20000731 (Red Hat Linux 7.1 2.96-98)) #1 SMP Thu Sep 6 17:09:31
EDT 2001
>
> Interestingly enough, if I change my $JAVA_HOME to use jdk1.4.2_03
instead, this tomcat shutdown problem with axis leaving threads running goes
away.
>
> Also, when I leave my jdk at 1.3.1_09, and just move the axis
subdir/webapp out of the tomcat webapps directory, the problem also goes
away.  So it's definetly related to the axis webapp.  But certainly
interesting that the 1.4 jdk fixes as well..but that causes other issues for
my app so I really want to run it with my $JAVA_HOME set to use jdk1.3.1_09.
I'm not quite certain why my local $JAVA_HOME jdk would cause any difference
on how tomcat/axis shuts down though.
>
> Any ideas on what's causing this or how to fix?
>
> Thanks!
> -Craig
>
>



Mime
View raw message