axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henry...@expeditors.com
Subject Re: Classpath?
Date Wed, 07 Apr 2004 15:44:33 GMT
The class GetQuote is not in axis.jar and so not in your class path. First 
make sure that you have the file GetQuote.class in your

%AXIS_LIB%\WEB-INF\classes\samples\stock

folder and then add this to your class path 

%AXIS_LIB%\WEB-INF\classes
------------------------------------------------------------------------------------------------------
Henry Li
henry.li@expeditors.com
ext: 3134
------------------------------------------------------------------------------------------------------




chudzikr@comcast.net
04/06/2004 10:05 PM
Please respond to axis-user

 
        To:     axis-user@ws.apache.org
        cc:     (bcc: Henry Li/IS/Expeditors)
        Subject:        Classpath?

Can anyone offer any help on what I'm pretty sure is a CLASSPATH issue? 
This is a re-post, and I apologize, but I'm pulling my hair out -- I've 
tried all sorts of classpath combinations and configurations.  I thought I 
had everything set when I got this:

C:\axis-1_1\samples\stock>java -cp %AXISCLASSPATH% 
org.apache.axis.client.AdminClient 
-lhttp://localhost:8080/axis/services/AdminService deploy.wsdd
Processing file deploy.wsdd
<Admin>Done processing</Admin>

I thought I was good to go.  But then I tried the next step and got this:

C:\axis-1_1\samples\stock>java -cp .;%AXISCLASSPATH% 
samples.stock.GetQuote  -lhttp://localhost:8080/axis/servlet/AxisServlet 
-uuser1 -wpass1 XXX
Exception in thread "main" java.lang.NoClassDefFoundError: 
samples/stock/GetQuote

Again, here are my path settings:

AXIS_HOME: c:\axis-1_1

AXIS_LIB: %AXIS_HOME%\lib

AXISCLASSPATH: 
%AXIS_LIB%\axis.jar;%AXIS_LIB%\commons-discovery.jar;%AXIS_LIB%\commons-logging.jar;%AXIS_LIB%\jaxrpc.jar;%AXIS_LIB%\saaj.jar;%AXIS_LIB%\log4j-1.2.8.jar;%AXIS_LIB%\mail.jar

CLASSPATH:  .;C:\ServletDevel;C:\Program Files\Apache Software 
Foundation\Tomcat 5.0\common\lib\servlet-api.jar;C:\Program Files\Apache 
Software Foundation\Tomcat 5.0\common\endorsed\xercesImpl.jar;C:\Program 
Files\Apache Software Foundation\Tomcat 
5.0\common\endorsed\xmlParserAPIs.jar;%AXISCLASSPATH%;C:\axis-1_1\samples

CATALINA_HOME: C:\Program Files\Apache Software Foundation\Tomcat 5.0

thanks,

-Rob

--
rob@chudzik.com



Mime
View raw message