axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mshet...@binghamton.edu
Subject Re: "Unique" classpath problem
Date Sat, 24 Apr 2004 19:39:26 GMT
hi ,
You have to create your classpath in .bashrc file . try compiling all the
files in your samples directory .

Secondly the errors always happen in .bashrc file . I am having a very bad
experience. DO NOT use any environment varibles in the file itself . ie if
you want to set a classpath DONT DO ${JAVA_HOME}/classes/myjar.jar ,
instead write comprehensively like /home/lion//classes/myjar.jar . I dont
know why , I was not able to get the environment variables in my bashrc
file .

Last but not the least do source .bashrc and then type 'env' to see all your
environment variables.

regards
Mayur

> Shaun,
>
> I have no experience with linux, but I have a few questions that might
> help
> you zero in on your problem.
>
> You mention two run-time errors in this thread. Your fist message reported
> "Exception in thread "main" java.lang.NoClassDefFoundError," and your
> second
> message reported "Unrecognized option: -l Could not create the Java
> virtual
> machine." Are you still getting both errors? The former looks like a
> classpath problem, but the latter does not.
>
> You say that you can't echo the $AXIS_Home directory. What is your $Home
> variable set to, since it detremines the value of $AXIS_HOME, $AXIS_LIB,
> and
> $AXISCLASSPATH?
>
> Silly question, but has your AdminCLient class been compiled?
>
>
>
>
>
>>From: shaun lim <psicokhel@yahoo.com>
>>Reply-To: axis-user@ws.apache.org
>>To: axis-user@ws.apache.org
>>Subject: Re: "Unique" classpath problem
>>Date: Sat, 24 Apr 2004 08:12:22 -0700 (PDT)
>>
>>Hi Mark! thanks for the reply. Yup i typed -l as in l for Lion. i have a
>>feelings its cause my classpath isn't set properly because i'm unable to
>>echo the $AXIS_HOME directory.
>>
>>Am i supposed to set the $AXIS_HOME,$AXISLIB etc in the bash_profile or
>>bashrc? sorry i'm almost a total linux noob.
>>
>>Anybody running axis/tomcat on linux? Help? Thanks..
>>
>>Mark Leone <markleone923@hotmail.com> wrote:
>>Are you typing -1 (dash ) or -l (dash ) for the
>>option? They look identical in some fonts. Looks like your message is
>>related to the option you specifed and not the classpath.
>>
>>
>> >From: shaun lim
>>
>> >Reply-To: axis-user@ws.apache.org
>> >To: axis-user@ws.apache.org
>> >Subject: Re: "Unique" classpath problem
>> >Date: Fri, 23 Apr 2004 21:44:17 -0700 (PDT)
>> >
>> >oops im sorry i left out the "deploy.wsdd"
>> >
>> >its supposed to be:
>> >
>> >When i try:
>> >[shaun@localhost stock]$ java -cp $AXISCLASSPATH
>> >org.apache.axis.client.AdminClient -l
>> >http://localhost:8080/axis/services/AdminService deploy.wsdd
>> >
>> >I get:
>> >Unrecognized option: -l
>> >Could not create the Java virtual machine.
>> >
>> >
>> >
>> >shaun lim
>>wrote:
>> >Hi guys, maybe its the fact that im a newbie to both
>> >linux and axis, but no one else seems to be having my
>> >kind of classpath problems.
>> >
>> >Please help if you can =)
>> >
>> >Here goes, I installed axis 1.1 on tomcat4.06 that
>> >comes with NetBeans 3.5.1 by copying the
>> >axis-1_1/webapps/axis folder to my tomcat webapps
>> >folder as instructed by the tutorial.
>> >
>> >Then i set my class path as follows:
>> >
>> ># .bash_profile
>> >
>> ># Get the aliases and functions
>> >if [ -f ~/.bashrc ]; then
>> >. ~/.bashrc
>> >fi
>> >
>> ># User specific environment and startup programs
>> >
>> >PATH=$PATH:$HOME/bin
>> >PATH=$HOME/SUNWappserver/jdk/bin:$PATH
>> >
>> >set AXIS_HOME=$HOME/web/axis-1_1
>> >set AXIS_LIB=$AXIS_HOME/lib
>> >set
>> >AXISCLASSPATH=$AXIS_LIB/axis.jar:$AXIS_LIB/commons-discovery.jar:
>> >
>> >$AXIS_LIB/commons-logging.jar:$AXIS_LIB/jaxrpc.jar:$AXIS_LIB/saaj.jar:
>> >
>> >$AXIS_LIB/log4j-1.2.8.jar:$AXIS_LIB/xml-apis.jar:$AXIS_LIB/xercesImpl.jar:$HOME/web/axis-1_1
>> >
>> >PATH=$AXISCLASSPATH:$PATH
>> >export AXIS_HOME; export AXIS_LIB; export
>> >AXISCLASSPATH
>> >export PATH
>> >unset USERNAME
>> >
>> >-
>> >Is there anything wrong with my classpath? My axis
>> >installation validates fine but i can't seem to access
>> >the AdminClient.
>> >
>> >I get the following errors:
>> >
>> >When i try:
>> >[shaun@localhost stock]$ java -cp $AXISCLASSPATH
>> >org.apache.axis.client.AdminClient -l
>> >http://localhost:8080/axis/services/AdminService
>> >
>> >I get:
>> >Unrecognized option: -l
>> >Could not create the Java virtual machine.
>> >
>> >When i try:
>> >[shaun@localhost stock]$ java
>> >org.apache.axis.client.AdminClient -l
>> >http://localhost:8080/axis/services/AdminService
>> >
>> >I get:
>> >Exception in thread "main"
>> >java.lang.NoClassDefFoundError:
>> >org/apache/axis/client/AdminClient
>> >
>> >Please help guys..this is really furstrating.
>> >
>> >I saw that some folks actually set their $AXISHOME as
>> >the copied axis directory in their tomcat/webapps. is
>> >that correct? Also, i already copied the jaxrpc.jar
>> >and saaj.jar to the tomcat/common/lib.
>> >
>> >Thanks a million in advance.
>> >
>> >
>> >
>> >
>> >__________________________________
>> >Do you Yahoo!?
>> >Yahoo! Photos: High-quality 4x6 digital prints for 25¢
>> >http://photos.yahoo.com/ph/print_splash
>> >
>> >---------------------------------
>> >Do you Yahoo!?
>> >Yahoo! Photos: High-quality 4x6 digital prints for 25¢
>>
>>_________________________________________________________________
>>FREE pop-up blocking with the new MSN Toolbar – get it now!
>>http://toolbar.msn.com/go/onm00200415ave/direct/01/
>>
>>
>>---------------------------------
>>Do you Yahoo!?
>>Yahoo! Photos: High-quality 4x6 digital prints for 25¢
>
> _________________________________________________________________
> Watch LIVE baseball games on your computer with MLB.TV, included with MSN
> Premium!
> http://join.msn.com/?page=features/mlb&pgmarket=en-us/go/onm00200439ave/direct/01/
>
>
>


Mime
View raw message