axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From shaun lim <psicok...@yahoo.com>
Subject Re: "Unique" classpath problem
Date Sat, 24 Apr 2004 04:44:17 GMT
oops im sorry i left out the "deploy.wsdd" 
 
its supposed to be:
 
When i try:
[shaun@localhost stock]$ java -cp $AXISCLASSPATH
org.apache.axis.client.AdminClient -l
http://localhost:8080/axis/services/AdminService deploy.wsdd

I get:
Unrecognized option: -l
Could not create the Java virtual machine.
 


shaun lim <psicokhel@yahoo.com> wrote:
Hi guys, maybe its the fact that im a newbie to both
linux and axis, but no one else seems to be having my
kind of classpath problems.

Please help if you can =)

Here goes, I installed axis 1.1 on tomcat4.06 that
comes with NetBeans 3.5.1 by copying the
axis-1_1/webapps/axis folder to my tomcat webapps
folder as instructed by the tutorial.

Then i set my class path as follows:

# .bash_profile

# Get the aliases and functions
if [ -f ~/.bashrc ]; then
. ~/.bashrc
fi

# User specific environment and startup programs

PATH=$PATH:$HOME/bin
PATH=$HOME/SUNWappserver/jdk/bin:$PATH

set AXIS_HOME=$HOME/web/axis-1_1
set AXIS_LIB=$AXIS_HOME/lib
set
AXISCLASSPATH=$AXIS_LIB/axis.jar:$AXIS_LIB/commons-discovery.jar:

$AXIS_LIB/commons-logging.jar:$AXIS_LIB/jaxrpc.jar:$AXIS_LIB/saaj.jar:

$AXIS_LIB/log4j-1.2.8.jar:$AXIS_LIB/xml-apis.jar:$AXIS_LIB/xercesImpl.jar:$HOME/web/axis-1_1

PATH=$AXISCLASSPATH:$PATH
export AXIS_HOME; export AXIS_LIB; export
AXISCLASSPATH
export PATH
unset USERNAME

-
Is there anything wrong with my classpath? My axis
installation validates fine but i can't seem to access
the AdminClient.

I get the following errors:

When i try:
[shaun@localhost stock]$ java -cp $AXISCLASSPATH
org.apache.axis.client.AdminClient -l
http://localhost:8080/axis/services/AdminService

I get:
Unrecognized option: -l
Could not create the Java virtual machine.

When i try:
[shaun@localhost stock]$ java
org.apache.axis.client.AdminClient -l
http://localhost:8080/axis/services/AdminService

I get:
Exception in thread "main"
java.lang.NoClassDefFoundError:
org/apache/axis/client/AdminClient

Please help guys..this is really furstrating.

I saw that some folks actually set their $AXISHOME as
the copied axis directory in their tomcat/webapps. is
that correct? Also, i already copied the jaxrpc.jar
and saaj.jar to the tomcat/common/lib.

Thanks a million in advance.




__________________________________
Do you Yahoo!?
Yahoo! Photos: High-quality 4x6 digital prints for 25
http://photos.yahoo.com/ph/print_splash
		
---------------------------------
Do you Yahoo!?
Yahoo! Photos: High-quality 4x6 digital prints for 25
Mime
View raw message