axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Parul.Jo...@Expeditors.com
Subject Re: No serializer found for class
Date Fri, 20 Feb 2004 18:39:16 GMT
Hi there,
I am extremely new to Axis and SOAP, and am trying to solve this for the 
past 2 days, without and luck.

I am running into a problem when I am trying to deserialize incoming data.
I get the following exception. 
SimpleDeserializer encountered a child element, which is NOT expected, in 
something it was trying to deserialize.
        at 
org.apache.axis.encoding.ser.SimpleDeserializer.onStartChild(SimpleDeserializer.j

I read thru' many of the posts, and I have registered all my sub-classes 
with BeanSerializers and De-serializer. I still get this exception.
My return type is a complex type which has 2 other complex types in it.
<outMsg>
        <header>
        <requests xsi:type="Array" arrayType="SearchRequest[1]">
                <SearchRequest> 
                        ......
                 </SearchRequest>
        </request>
        <columnHeadings type="soap:Array"/>
        </header>
        <answer>
                <userErrors> </userErrors>
                <results xsi:type="Array" arrayType="SearchView[3]">
                        <SearchView> ....   </SearchView>
                <systemErrors> </SystemErrors>
        </answer>
</outMsg>

I have registered outMsg, header, answer, SearchView, SearchRequest, 
userErrors, systemErrors.  Basically I have registered all the complex 
types that I expect in the return object. 
I am registering it like this. nameSpace is ="", since there isn't one 
defined in the wdss.
        qName = new javax.xml.namespace.QName(nameSpace, "outMsg");
        call.registerTypeMapping(EIResponse.class, qName, beanSF, beanDF);

I don't know if I'm registering it incorrect, since I'm not sure what I 
should put in the namespace, I tried several different things but none 
work. 

Any Help will be greatly appreciated.


Thanks,
Parul
Mime
View raw message