axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pani, Gourav" <gourav.p...@brightpoint.com>
Subject RE: SimpleDeserializer Error
Date Tue, 06 Jan 2004 18:54:47 GMT
Is there some sort of a workaround to this?
-----Original Message-----
From: Richard Martin [mailto:rmarti@essex.ac.uk]
Sent: Tuesday, January 06, 2004 1:55 PM
To: axis-user@ws.apache.org
Subject: RE: SimpleDeserializer Error


Yes, this appears to be a bug: 
 
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17484
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17484> 
 
And there was another email about it not 3 or 4 weeks ago:
http://www.mail-archive.com/axis-user@xml.apache.org/msg16191.html
<http://www.mail-archive.com/axis-user@xml.apache.org/msg16191.html> 
 
It seems that the deserialiser has problems deserialising arrays of custom
objects, but that's just a first glance.
 
Regards, 
 
Richard
 

  _____  

From: Pani, Gourav [mailto:gourav.pani@brightpoint.com] 
Sent: 06 January 2004 18:10
To: 'axis-user@ws.apache.org'
Subject: SimpleDeserializer Error
 
The following is the error I get when I post to a service.  
org.xml.sax.SAXException: Error: SimpleDeserializer encountered a child
element, which is NOT expected, in something it was trying to deserialize.
 
My transaction sends an array of a serializable object and the construction
of the object is consistent with the WSDL.  Has anyone else encountered this
problem?
 
Thanks.
 

Mime
View raw message