axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jacob Kjome <h...@visi.com>
Subject Re: Need urgent help in installing AXIS
Date Tue, 13 Jan 2004 04:53:16 GMT
At 08:29 PM 1/12/2004 -0800, you wrote:
>Hi Sabahat!
>
>The best way to eliminate this problem/exception is to remove the 
>xerces.jar from tomcat/common/lib if you had copied it by mistake. This 
>problem occurs if you have multiple parsers. Apart from the tomcat libs, 
>you just need to have activation.jar and mail.jar in your tomcat/common/lib.

I wouldn't do that.  Leave the xercesImpl.jar there alone.... or, 
minimally, upgrade to the latest release of Xerces and make sure to replace 
xmlParserAPIs.jar as well with the one that comes with the latest release 
(or with xml-apis.jar which is the preferred jar as the xmlParserAPIs.jar 
name is deprecated).  Remove the XercesImpl.jar from Axis and move 
jaxrpc.jar and saaj.jar to CATALINA_HOME/common/lib.  Of course, also add 
activation.jar and mail.jar as Sai has said.  I would also upgrade 
log4j.jar to the latest 1.2.8, while you are at it.  And, why not upgrade 
to a more recent Tomcat version than 4.0.4.  That's some old stuff.  5.0.16 
is the latest and very stable.

Anyway, things should work.

Jake

>
>Hope this works
>Sai


Mime
View raw message