axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ashley Waite <Guvni...@netscape.net>
Subject Re: WSDL2Java problem
Date Wed, 28 Jan 2004 06:04:27 GMT
Safdar,

I believe you will find that the Java specs now state that any jars that 
change/add-to the java.* and javax.* packages must be in the endorsed 
directory of your JRE/JDK.
If that is not the issue, I have had many similar issues with other 
applications and it was easily solved by moving all the jars into the 
JRE/JDK extensions directory.
Failing all else, use the -classpath command line switch to explicitly 
add the jar file involved into the path.


Safdar Ali wrote:

> Hello,
> I am getting the following error while using WSDL2Java tool...
>  
> C:\axis-1_1\samples\addr>java org.apache.axis.wsdl.WSDL2Java Address.wsdl
> Exception in thread "main" java.lang.NoClassDefFoundError: 
> javax.wsdl.Definition
>         at 
> org.apache.axis.wsdl.toJava.JavaGeneratorFactory.class$(JavaGeneratorFactory.java:163)
>         at 
> org.apache.axis.wsdl.toJava.JavaGeneratorFactory.addDefinitionGenerators(JavaGeneratorFactory.java:163)
>         at 
> org.apache.axis.wsdl.toJava.JavaGeneratorFactory.addGenerators(JavaGeneratorFactory.java:133)
>         at 
> org.apache.axis.wsdl.toJava.JavaGeneratorFactory.<init>(JavaGeneratorFactory.java:120)
>         at org.apache.axis.wsdl.toJava.Emitter.<init>(Emitter.java:120)
>         at org.apache.axis.wsdl.WSDL2Java.createParser(WSDL2Java.java:172)
>         at org.apache.axis.wsdl.gen.WSDL2.<init>(WSDL2.java:113)
>         at org.apache.axis.wsdl.WSDL2Java.<init>(WSDL2Java.java:161)
>         at org.apache.axis.wsdl.WSDL2Java.main(WSDL2Java.java:289)
>  
> All of the required .jar files exist in classpath... and even I have 
> extracted the 3 .jar files into the Java_Home\lib folder... and it 
> still doesn't work....
> I would be thankful if get the suggestion...
>  
> Rgrds.
> Safdar.



Mime
View raw message