axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pathuru, Kiran" <Kiran.Path...@ect-telecoms.de>
Subject RE: problem in running the admin client
Date Thu, 29 Jan 2004 12:30:13 GMT
1) Try to run the command from axis direcotry like this
   c:\axis>java -classpath . samples.stock.GetQuote -uuser......
   This will fix the first problem.
2) If you set the classpath in windows, already opened cmd prompts can not
get the updated classpath. check this by seeing the classpath from the cmd
prompt. Open a new cmd prompt and this should work provided you set the
classpath properly..

hope this helps

kiran

-----Original Message-----
From: Noelle Ng [mailto:ytng@it.uts.edu.au]
Sent: Thursday, January 29, 2004 6:37 AM
To: axis-user@ws.apache.org
Cc: ytng@it.uts.edu.au
Subject: problem in running the admin client



1/ after i have set the classpath, i have trouble in running the admin
client: i execute the below command:
c:\axis\samples\stock>java samples.stock.GetQuote -uuser1 -wpass1 XXX
-s/axis/StockQuoteService.jws

and it gives me this error:
Exception in thread "main" java.lang.NoClassDefFoundError:
samples/stock/GetQuote

anyone could suggest how to fix it?

2/ following the online documentation on running the admin client:
C:\axis\samples\stock>java -cp %classpath%
org.apache.axis.client.AdminClient
-lhttp://localhost:8080/axis/services/AdminService deploy.wsdd

 it gives me this error:

Exception in thread "main" java.lang.NoClassDefFoundError:
org/apache/axis/clien
t/AdminClient

any idea ?

Noelle

Mime
View raw message