axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Feng yuan" <flubw...@hotmail.com>
Subject problem when generating WSDL from the deploeyed service
Date Sat, 27 Dec 2003 13:54:38 GMT
Hi all,
I have deployed a web service using Axis and Tomcat.

When I using the link: 
http://localhost:8080/axis/services/LookyBookServiceSoap
I can get theright result:
***************************
LookyBookServiceSoap
Hi there, this is an AXIS service!

Perhaps there will be a form for invoking the service here...
***************************
I think this can mean I have deployed the service correctly.

But when I using the link: 
http://localhost:8080/axis/services/LookyBookServiceSoap?wsdl
I got the exception:
***************************
AXIS error
Sorry, something seems to have gone wrong... here are the details:

Fault - makeTypeElement() was told to create a type 
"{http://nss.m-commerce.org/webservices/books}>DoKeywordSearch", with no 
containing element
AxisFault
faultCode: 
{http://schemas.xmlsoap.org/soap/envelope/}Server.generalException
faultSubcode:
faultString: makeTypeElement() was told to create a type 
"{http://nss.m-commerce.org/webservices/books}>DoKeywordSearch", with no 
containing element
faultActor:
faultNode:
faultDetail:

********************************
Have somebody met this problem? If it is a stupid question, can somebody 
give me a hint how to resolve it? Thanks in advance.

Regards,
Feng

_________________________________________________________________
Protect your PC - get McAfee.com VirusScan Online 
http://clinic.mcafee.com/clinic/ibuy/campaign.asp?cid=3963


Mime
View raw message