axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dave sag <apache-a...@davesag.com>
Subject Installation problems Step 7
Date Mon, 10 Nov 2003 16:53:17 GMT
Hi people, I am an Axis newbie, but an old hand at java and servlets etc.

I am walking through the installation instructions and everything 
works fine up to step 7.

In step 7 it says,

"This step is optional, but highly recommended. For illustrative 
purposes, it is presumed that you have installed and deployed the 
stock quote demo.

* Change directory to the distribution directory for xml-axis and 
execute the following command (or its Unix equivalent):
On Windows   java -cp .;%AXISCLASSPATH% samples.stock.GetQuote
   -lhttp://localhost:8080/axis/servlet/AxisServlet -uuser1
   -wpass1 XXX On UNIX java -cp $AXISCLASSPATH
   samples.stock.GetQuote
   -lhttp://localhost:8080/axis/servlet/AxisServlet -uuser1
   -wpass1 XXX


* You should get back "55.25" as a result."

so, I am on UNIX, (Mac OSX 10.3) bash shell.  what is my 
"distribution directory"?

is it
a) where I installed axis? eg $AXIS_HOME
b) where I installed axis in Tomcat?
c) some other place?

wherever I have tried the following line in all manner of places.
java -cp $AXISCLASSPATH samples.stock.GetQuote
   -lhttp://localhost:8080/axis/servlet/AxisServlet -uuser1
   -wpass1 XXX

and always get the old familiar java.lang.NoClassDefFoundError: 
samples/stock/GetQuote

I know this is a total dummy question but nothing I do seems to help. 
My AXISCLASSPATH is okay because all the preceeding steps 1 thru 6 
worked a-okay. but step 7 has thrown me and I can see no logical 
reason why it should fail, other than the docs are wrong.

Anyone else got step 7 to work?  what am i doing wrong?

dave


Mime
View raw message