axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillaume Sauthier <Guillaume.Sauth...@Objectweb.org>
Subject Re: Réf. : Re: Réf. : Re: Unable to locate avalidEngineConfigurationFactory
Date Thu, 27 Nov 2003 13:38:51 GMT
The error you get should come from discovery component. Is it in webapp
and in common libs at the same time ?

All commons libs will be available to the webapps... try to not have
libs twice .

Regards
Guillaume


valerie.bauche@bull.net wrote:
> 
> All axis jars are located on TOMCAT_HOME/webapps/axis/WEB-INF/lib and I add
> some of them on TOMCAT_HOME/common/lib :
> common-logging, common-discovery, jaxrpc, wsd4j and saaj
> 
> Valerie
> 
> Guillaume Sauthier <Guillaume.Sauthier@Objectweb.org>@bull.net sur
> 26/11/2003 16:53:16
> 
> Veuillez répondre à axis-user@ws.apache.org
> 
> Envoyé par :      Guillaume.Sauthier@bull.net
> 
> Pour : axis-user@ws.apache.org
> cc :
> Objet :     Re: Réf. : Re: Unable to locate a
>        validEngineConfigurationFactory
> 
> IMO It's a classLoader problem.
> Where are located axis jars on the tomcat server ?
> 
> valerie.bauche@bull.net wrote:
> >
> > I use axis 1.1 and I didn't modify any of the axis classes.
> > Perhaps the context of my problem could help :
> > I call a first axis service which has an handler
> > This handler call an external class (not a web service) located in
> > TOMCAT_HOME/common/classes
> > This external class call a second axis web service : this is where I get
> my
> > error
> >
> > Valerie
> >
> > Guillaume Sauthier <Guillaume.Sauthier@Objectweb.org>@bull.net sur
> > 26/11/2003 15:45:53
> >
> > Veuillez répondre à axis-user@ws.apache.org
> >
> > Envoyé par :      Guillaume.Sauthier@bull.net
> >
> > Pour : axis-user@ws.apache.org
> > cc :
> > Objet :     Re: Unable to locate a valid EngineConfigurationFactory
> >
> > Hello
> > Which version of Axis do you use ?
> > have you change in anyway the classes mentionned below ?
> >
> > It seems that default Factory classes have been tried but they do'nt
> > provide the static method newFactory(Object).
> >
> > Regards
> > Guillaume
> >
> > valerie.bauche@bull.net wrote:
> > >
> > > The code :
> > > org.apache.axis.client.Service  service = new Service();
> > >
> > > generates the following error :
> > >
> > > - Factory
> org.apache.axis.configuration.EngineConfigurationFactoryServlet
> > > Ignored: missing required method: public static
> > EngineConfigurationFactory
> > > newFactory(Object).
> > > - Factory
> org.apache.axis.configuration.EngineConfigurationFactoryDefault
> > > Ignored: missing required method: public static
> > EngineConfigurationFactory
> > > newFactory(Object).
> > > - Unable to locate a valid EngineConfigurationFactory
> > >
> > > Whath does this mean ?
> > >
>  >  > Valerie

Mime
View raw message