axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Fricke <cfri...@rz.uni-potsdam.de>
Subject RE: Axis_C error parsing WSDL
Date Sat, 29 Nov 2003 23:14:17 GMT
Hi,

Thanks for the settings. Now my environment works.

So i have the next problem. I plan to implement a client to ask the
index service from the Globus Toolkit 3. To get the stubs and skeletons
i have to read the wsdl descriptions. But every description i took fails
with several errors like .NullPointerException or
org.apache.axis.wsdl.wsdl2ws.WrapperFault: the service does not exists .
The Globus Toolkit 3 is based on Axis-Java. 

Can anybody help me doing this?

Christian Fricke

  

Am Fr, 2003-11-28 um 12.56 schrieb damitha@opensource.lk:
> Hi Chris,
> 
>  may be your jar files are diffenrent. I'll check with your java version
> and inform you.
> 
> anyway, here is my environment profile.
> ----------------------------------

> regds
> 
> damitha
> 
> 
> > Hi,
> >
> > the message says that a resource is missing:
> >
> > ---snip
> > Caused by: java.util.MissingResourceException: Cannot find resource
> > 'org.apache.axis.i18n.resource'
> > ----------------------------------snip
> >
> > In the jar file only a file named "resource.properties" is locatable. So
> > i dont know what is missing ?
> > Can you send me a snap of your environment settings?
> > Maybe i'm able to locate a difference.
> >
> > Best regards
> > Christian Fricke
> >
> >
> >
> > Zitat von damitha@opensource.lk:
> >
> >> Hi Christian,
> >>
> >>
> >> > I've still done all described in the user guide. So i took the
> >> sources and made all by hand, use the right axis jars and the wsdl
> >> coming with the samples.
> >> >
> >> > My System is SuSE 9.0 / Java 1.4.2 / Xerces 2.3.0-33 / apache 1.3.
> >>
> >>
> >>
> >> I tested with java version 1.4.0_03 and working fine. Susantha, does
> >> it make any difference
> >> between java 1.4.2 and 1.4.0_03?
> >>
> >>
> >> >
> >> > I dont know what i have forgotten ?  ;)
> >> >
> >> > Do you have any ideas? Maybe i have to install red-hat8.0/9.0 at an
> >> other computer and try axis? But thats far too much trouble for me
> >> :)
> >>
> >>
> >>
> >> No no, this has nothing to do with your linux distribution as long as
> >> you have the correct jvm running. the problem comes when you runs a
> >> java command , right?
> >>
> >>
> >>
> >> regds damitha
> >> >
> >> >
> >> > Am Do, 2003-11-27 um 05.04 schrieb Susantha Kumara:
> >> >> Hi Christian Fricke,
> >> >>
> >> >> It seems that there is something wrong with the wsdl you used.
> >> Another possibility is that the required axis jar files in your
> >> class path may be incompatible.
> >> >>
> >> >> Please use the axis jars in the /lib/axisjava/ foloder of Axis C++
> >> distribution.
> >> >>
> >> >> If you still get the problem let me have the wsdl you used.
> >> >>
> >> >> Thanks,
> >> >>
> >> >> Susantha.
> >> >>
> >> >>
> >> >> > -----Original Message-----
> >> >> > From: Christian Fricke [mailto:cfricke@rz.uni-potsdam.de]
> >> >> > Sent: Thursday, November 27, 2003 4:49 AM
> >> >> > To: axis-user@ws.apache.org
> >> >> > Subject: Axis_C error parsing WSDL
> >> >> >
> >> >> >
> >> >> > Hello,
> >> >> >
> >> >> > I have installed the Axis (C++) alpha release. I have all done
as
> >> >> described in the documentation at the website.
> >> >> >
> >> >> > While making the server skeleton and wrappers i got the following
> >> >> error:
> >> >> >
> >> >> > --snip-------------------------------------------------------------
> >> >> java org.apache.axis.wsdl.wsdl2ws.WSDL2Ws InteropBase.wsdl
> >> >> > -oGenClassesServer -client
> >> >> > args =
> >> >> > args =
> >> >> > 1
> >> >> > Exception in thread "main" java.lang.ExceptionInInitializerError
> >> >> >         at
> >> org.apache.axis.utils.Messages.<clinit>(Messages.java:75)
> >> >> at
> >> >> >
> >> org.apache.axis.utils.JavaUtils.isAttachmentSupported(JavaUtils.java:1185)
> >> >> >         at
> >> >> > org.apache.axis.encoding.DefaultTypeMappingImpl.<init>(DefaultType
> >> >> MappingImpl.java:151)
> >> >> >         at
> >> >> > org.apache.axis.encoding.DefaultSOAPEncodingTypeMappingImpl.<init>
> >> >> (DefaultSOAPEncodingTypeMappingImpl.java:79)
> >> >> >         at
> >> >> > org.apache.axis.encoding.DefaultSOAPEncodingTypeMappingImpl.create
> >> >> (DefaultSOAPEncodingTypeMappingImpl.java:73)
> >> >> >         at
> >> >> > org.apache.axis.wsdl.gen.NoopFactory$1.<init>(NoopFactory.java:112)
> >> >> >         at
> >> >> > org.apache.axis.wsdl.gen.NoopFactory.getBaseTypeMapping(NoopFactor
> >> >> y.java:111)
> >> >> >         at org.apache.axis.wsdl.gen.Parser.run(Parser.java:204)
> >> at
> >> >> org.apache.axis.wsdl.wsdl2ws.WSDL2Ws.<init>(WSDL2Ws.java:122)
at
> >> >> org.apache.axis.wsdl.wsdl2ws.WSDL2Ws.main(WSDL2Ws.java:514)
> >> >> > Caused by: java.util.MissingResourceException: Cannot find
> >> resource
> >> >> 'org.apache.axis.i18n.resource'
> >> >> >         at
> >> >> > org.apache.axis.i18n.ProjectResourceBundle.getBundle(ProjectResour
> >> >> ceBundle.java:327)
> >> >> >         at
> >> >> >
> >> org.apache.axis.i18n.MessagesConstants.<clinit>(MessagesConstants.java:71)
> >> >> >         ... 10 more
> >> >> > -----------------------------------------------------snip---------
> >> >> ------------------------------------------------->
> >> >> ------------------------- --
> >> >> >
> >> >> >
> >> >> > So there is a error with the   java.lang.Exception error, but
i
> >> can
> >> >> not solve this.
> >> >> >
> >> >> > Are there any hints for me, because i'm very new to java, so dont
> >> >> understand the message.
> >> >> >
> >> >> >
> >> >> > regards Christian Fricke
> >> >> >
> >> >> >
> >> >> >
> >> >> >
> >> >>
> >>
> >>
> >>
> >>
> 
> 
> 


Mime
View raw message