axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric George <eric.geo...@critrade.com>
Subject schema namespace problem
Date Tue, 28 Oct 2003 18:11:25 GMT
I am having a strange issue with wsdl being generated by java2wsdl.  It
seems to honor my requested namespace everywhere except for the first
<schema> tag in the <wsdl:types> section.  For example, my java2wsdl task
looks like this.

<axis-java2wsdl
  bindingname="TradeServerSoapBinding"
  location="http://www.critrade.com/services/"


namespace="http://TradeService${hour_stamp}.webservices.services.critrade.co
m"

  classname="com.critrade.services.backoffice.trade.TradeServer"
  output="${wsdl}/TradeServer.wsdl"
  extraclasses="com.critrade.services.backoffice.trade.BondTradeBean" >
  <mapping
namespace="http://TradeService${hour_stamp}.webservices.services.critrade.co
m"
           package="com.critrade.services.webservices" />
</axis-java2wsdl>

And the generated wsdl looks something like this.

<wsdl:definitions

targetNamespace="http://TradeService20031028_09.webservices.services.critrad
e.com"
   correct ns
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  xmlns="http://schemas.xmlsoap.org/wsdl/"
xmlns:apachesoap="http://xml.apache.org/xml-soap"

xmlns:impl="http://TradeService20031028_09.webservices.services.critrade.com
"

xmlns:intf="http://TradeService20031028_09.webservices.services.critrade.com
"
  xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"
  xmlns:tns="http://trade.backoffice.services.critrade.com"
  xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
  xmlns:wsdlsoap="http://schemas.xmlsoap.org/wsdl/soap/"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema">
 <wsdl:types>
  <schema targetNamespace="http://trade.backoffice.services.critrade.com"
    incorrect ns           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
          xmlns="http://www.w3.org/2001/XMLSchema">
   <import namespace="http://schemas.xmlsoap.org/soap/encoding/"/>
   <complexType name="TradeBean">
    <sequence>
     <element name="tradeCommission" nillable="true" type="xsd:float"/>
    </sequence>
   </complexType>

   <!-- A bunch more complex types which correspond to my beans -->

  </schema>
  <schema
targetNamespace="http://TradeService20031028_09.webservices.services.critrad
e.com"
    correct ns
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
          xmlns="http://www.w3.org/2001/XMLSchema">
   <import namespace="http://schemas.xmlsoap.org/soap/encoding/"/>

   <!-- A bunch of array types -->

You can see that the namespace used for my bean objects is different than
the one used for the "standard" complex types like arrays.  Am I missing
some override flag in java2wsld or is it a bug?

Even if someone knows where in the axis code I go to make a fix, it would be
helpful.

Eric George
Computer Research Inc.
Software Engineer
ph: 303-297-2900x260
---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.532 / Virus Database: 326 - Release Date: 10/27/2003


Mime
View raw message