axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anne Thomas Manes <a...@manes.net>
Subject Re: SOAP versions
Date Mon, 01 Sep 2003 21:15:01 GMT
http://www.w3.org/2001/06/soap-envelope was the envelope namespace used in 
one of the SOAP 1.2 Working Drafts. Your service provider should regenerate 
the service using a standard version of SOAP -- either 1.1 or 1.2.

You can use Axis to invoke both 1.1 and 1.2 services. One of the Axis 1.1 
pre-beta builds supported this working draft namespace. Good luck finding 
it, though...

Anne

At 03:16 PM 9/1/2003 +0200, you wrote:
>I'm trying to write a simple SOAP client which sends a message to SOAP
>server bundled with some commercial j2ee application, but having Version
>mismatch problems.
>
>The default envelope namespace for that application is
>http://www.w3.org/2001/06/soap-envelope. Which SOAP version is that? I guess
>v1.0, since when I set Axis to SOAP 1.2 I can see
>xmlns:soapenv="http://www.w3.org/2002/12/soap-envelope" in the logs and when
>set to SOAP 1.1 (default) the namespace is
>xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/".
>
>If I have SOAP server which implements v1.0, can I still use Axis (I guess
>not). If not, which SOAP implementation I should use? Is Apache SOAP
>appropriate implementation?
>
>I just started with SOAP so if my terminology is incorrect, please be so
>kind to point me to the right direction. Those "SOAP client" and "SOAP
>server" formulations look suspicious :-)
>
>Thanks!
>
>Regards,
>Davor Cengija



Mime
View raw message