axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Harris" <JimHar...@blueyonder.co.uk>
Subject RE: AdminClient Exception...
Date Tue, 12 Aug 2003 21:49:16 GMT
You could try deploying just using the command:
java -cp %AXIS_CLASSPATH% org.apache.axis.client.AdminClient
emprel/sftm/webservice/cliente/deploy.wsdd

I believe this should work just fine - I can't remember what the -l
http://... does but if you look in the AdminClient help you may find it is
redundant as in my case...

Then again, you might just try editing the server-config.wsdd fule
manually - it is a LOT less hastle than using the AdminClient. Basically,
just go to your deploy.wsdd file and cut and paste the
<service>......</service> element and ALL its contents into the
server-config.wsdd file (in your axis/WEB-INF directory). Once done, restart
Tomcat (or whatever you are using) and your service is deployed.

I have answered several questions from people having trouble with the admin
client - seems the whole deployment process needs some work for a later axis
release... Wish I had the time!

HTH
Jim Harris

> -----Original Message-----
> From: Jorge Alberto Rodriguez Suarez [mailto:jars@recife.pe.gov.br]
> Sent: 12 August 2003 21:16
> To: axis-user@ws.apache.org
> Subject: AdminClient Exception...
>
>
> Hi there!
>
> When iam making:
>
> java -cp %AXIS_CLASSPATH%
> org.apache.axis.client.AdminClient
> -lhttp://pmat01:8080/axis/services/AdminS
> ervice emprel/sftm/webservice/cliente/deploy.wsdd
>
> triying to deploy my web service, iam reciving:
>
> Processing file emprel/sftm/webservice/cliente/deploy.wsdd
> Exception:: java.lang.reflect.InvocationTargetException
>
> Some idea???
>
> Thanks!
>
> Jorge.
>
>



Mime
View raw message