axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chen, Li (Research, YOH)" <ch...@research.ge.com>
Subject The AXIS engine could not find a target service to invoke!
Date Tue, 12 Aug 2003 15:37:36 GMT
Hi all,
	I am having a very strange problem with deploying some services in
Axis. I have running on my machine a JBoss 3.2.1 server with Tomcat 4.24.1,
and have successfully deployed a service under a folder (let's call it
myService.war, in the deploy directory of the JBoss installation).

Initially, the deployment configuration that worked is as follows:

<JBoss deploy folder>
	-myService.war
		-files here (.class files)

I have included the paths to those class files in my CLASSPATH variable, and
this initial config worked well.

However, today when I cleaned up the folders and rearranged them into:

<JBoss deploy folder>
	-myService.war
		-bin
			-files here (.class files)
		-src
			-files here (.java files)
		-other folders here

and did the following:

1) Updated the paths in my CLASSPATH variable,
2) Undeployed the services I deployed previously.
3) Redeployed the services (and checked via java
org.apache.axis.client.AdminClient list command)
4) Rebooted both machine and server,
5) Made sure classes compile under circumstances,
6) Moved the request handler that I wrote properly to the classes folder in
axis.war folder in the JBoss deploy directory (so I have two .war folder
pertaining to web services: axis.war and myService.war)

However, I still couldn't get my service to work and there is a message that
was returned to me (via TCPMonitor):

HTTP/1.1 500 Internal Server Error Content-Type: text/xml; charset=utf-8
Transfer-Encoding: chunked Date: Tue, 12 Aug 2003 15:29:09 GMT Server:
Apache Coyote/1.0 Connection: close  204 <?xml version="1.0"
encoding="UTF-8"?>
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
 <soapenv:Body>
  <soapenv:Fault>
   <faultcode
xmlns:ns1="http://xml.apache.org/axis/">ns1:Server.NoService</faultcode>
   <faultstring>The AXIS engine could not find a target service to invoke!
targetService is null</faultstring>
   <detail/>
  </soapenv:Fault>
 </soapenv:Body>
</soapenv:Envelope>

Can anybody help me with this problem? I believe there is something very
obvious that I missed in trying to solve this problem.

Thanks in advance,

Regards,

Lee


Mime
View raw message