axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Irial Conroy <irial.con...@am-beo.com>
Subject Setting xsi & xsd to XMLSchema 1999 not 2001
Date Wed, 27 Aug 2003 08:54:40 GMT
(Reposting as have had no responses and am stuck !)

> Hi,
> 
> I am connecting to a SOAP server which expects :
> <SOAP-ENV:Envelope
> xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
> SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
> xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
> xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"
> xmlns:xsd="http://www.w3.org/1999/XMLSchema"> 
> 
> i.e. XMLSchema 1999 not 2001
> 
> I am using Axis to generate a request - it is generated with
> 2001/XMLSchema.
> Can I get Axis to generate a SOAP request using XMLSchema 1999 ?
> 
> I saw a number of posts related to this dated the end of last year but
> none since.
> I have tried some of the options outlined
> (messageContext.setSchemaVersion() etc. but all to no avail...)
> At the time it didn't seem to be possible to do this (without tinkering
> with the Axis source code yourself).
> Is this still the case ?
> If not, how do I configure Axis to generate using XMLSchema 1999 ?
> 
> Any suggestions welcome...
> 
> (I am using Axis 1.1)
> 
> Thanks in advance,
> Irial

> 	Irial Conroy
> 	Software Engineer 
> 	Am-Beo Ltd.
> 	+353 91 730 814    Direct
> 	+353 91 730 737    Office
> 	+353 91 751 002    Fax
		www.am-beo.com
> 	------------------------------
> 	This message may contain proprietary and valuable information of
> Am-Beo. Am-Beo asserts its copyright to any proprietary information that
> may have been supplied and the proscription of third party disclosure of
> any such proprietary information.
> 
> 

Mime
View raw message