axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alireza Taherkordi" <taherko...@dpi2.dpi.net.ir>
Subject Problem in WSDL generation
Date Mon, 11 Aug 2003 14:21:08 GMT
Hi,

I've a problem with SimpleAxisServer,

I've a simple WebService, when run Axis from Jetty
and then refer to http://localhost:9090/services/adder?wsdl
I get WSDL , but when I test this with SimpleAxisServer
and when getting wsdl it sends AxisFault, such as this:
<?xml version="1.0" encoding="UTF-8" ?>
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<soapenv:Body>
 <soapenv:Fault>
   <faultcode
xmlns:ns1="http://xml.apache.org/axis/">ns1:Server.NoService</faultcode>
   <faultstring>The AXIS engine could not find a target service to invoke!
targetService is null</faultstring>
  <detail>
   <ns2:stackTrace xmlns:ns2="http://xml.apache.org/axis/">AxisFault
faultCode:
  {http://xml.apache.org/axis/}Server.NoService faultSubcode:
  faultString: The AXIS engine could not find a target
  service to invoke! targetService is null faultActor:
  faultNode: faultDetail: The AXIS engine could not
  find a target service to invoke! targetService is null
  at org.apache.axis.server.AxisServer.generateWSDL(AxisServer.java:492)
  at
org.apache.axis.transport.http.SimpleAxisWorker.run(SimpleAxisWorker.java:34
3)
  at java.lang.Thread.run(Thread.java:536)</ns2:stackTrace>
  </detail>
 </soapenv:Fault>
</soapenv:Body>
</soapenv:Envelope>

It seems that SimpleAxisServer uses "SimpleHTTP" as transport , is the error
because of this type of transport? (when using jetty or tomcat the transport
is "http")

Any help is greatly appreciated.

Best Regards
Alireza Taherkordi



Mime
View raw message