axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chen, Li (Research, YOH)" <ch...@research.ge.com>
Subject Mysterious AdminClient Error
Date Mon, 07 Jul 2003 20:24:21 GMT
Hi,
	I'm in the process of deploying a handler that gets to process an
incoming SOAP message before the actual "web service" class gets the
message. However, whenever I try to use the AdminClient
(org.apache.axis.client.AdminClient) to process the deploy.wsdd file, it
shows some unintelligible error message. Here is my simple wsdd file for the
handler:

<deployment xmlns="http://xml.apache.org/axis/wsdd/"
xmlns:java="http://xml.apache.org/axis/wsdd/providers/java">
 <!-- define the authentication handler configuration -->
 <handler name="a" type="a_class"></handler>
 
 <!-- define the service, using the authenticator handler we just defined
-->
 <service name="b" provider="java:RPC">
  <requestFlow>
   <handler type="a"/>
  </requestFlow>
 
  <parameter name="className" value="b"/>
  <parameter name="allowedMethods" value="*"/>
 </service>
</deployment>

(the names of the classes are changed to a, a_class, and b for posting
purposes.)

When I say:

C:..> java. org.apache.axis.client.AdminClient deploy.wsdd

the following error occurs:

 deploy.wsdd
- Processing file deploy.wsdd
- Exception:
AxisFault
 faultCode: {http://xml.apache.org/axis/}HTTP
 faultSubcode:
 faultString:
(500)%28class%3A+org%2Fapache%2Faxis%2Fserver%2FAxisServer%2C+meth
od%3A+getClientEngine+signature%3A+%28%29Lorg%2Fapache%2Faxis%2FAxisEngine%3
B%29
+Bad+type+in+putfield%2Fputstatic
 faultActor:
 faultNode:
 faultDetail:
        {}string: return code:  500
&lt;HTML&gt;
&lt;HEAD&gt;
&lt;TITLE&gt;Error 500 (class: org/apache/axis/server/AxisServer, method:
getCli
entEngine signature: ()Lorg/apache/axis/AxisEngine;) Bad type in
putfield/putsta
tic&lt;/TITLE&gt;
&lt;BODY&gt;
&lt;H2&gt;HTTP ERROR: 500 (class: org/apache/axis/server/AxisServer, method:
get
ClientEngine signature: ()Lorg/apache/axis/AxisEngine;) Bad type in
putfield/put
static&lt;/H2&gt;
RequestURI=/axis/services/AdminService

&lt;/BODY&gt;
&lt;/HTML&gt;


(500)%28class%3A+org%2Fapache%2Faxis%2Fserver%2FAxisServer%2C+method%3A+getC
lien
tEngine+signature%3A+%28%29Lorg%2Fapache%2Faxis%2FAxisEngine%3B%29+Bad+type+
in+p
utfield%2Fputstatic
        at
org.apache.axis.transport.http.HTTPSender.readFromSocket(HTTPSender.j
ava:630)
        at
org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:128)

        at
org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrateg
y.java:71)
        at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:150)
        at org.apache.axis.SimpleChain.invoke(SimpleChain.java:120)
        at org.apache.axis.client.AxisClient.invoke(AxisClient.java:180)
        at org.apache.axis.client.Call.invokeEngine(Call.java:2526)
        at org.apache.axis.client.Call.invoke(Call.java:2515)
        at org.apache.axis.client.Call.invoke(Call.java:1637)
        at org.apache.axis.client.AdminClient.process(AdminClient.java:355)
        at org.apache.axis.client.AdminClient.process(AdminClient.java:334)
        at org.apache.axis.client.AdminClient.process(AdminClient.java:341)
        at org.apache.axis.client.AdminClient.process(AdminClient.java:292)
        at org.apache.axis.client.AdminClient.main(AdminClient.java:377)

Has anyone else had this kind of error?

Thanks!

Mime
View raw message