axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Abhijat Thakur" <atha...@bdnacorp.com>
Subject wsdl
Date Mon, 28 Jul 2003 23:00:24 GMT
On publishing services i get a wsdl file of the type shown below with "wsdl" word is appened
at the start of the each node. The deployment descriptor is something like this.
 
<deployment name="test" xmlns=" http://xml.apache.org/axis/wsdd/" 
    xmlns:java=" http://xml.apache.org/axis/wsdd/providers/java">
 
  <service name="TestService" provider="java:RPC">
    <parameter name="className" value="com.bdna.pl.testing.Testing"/>
    <parameter name="allowedMethods" value="getTestMessage" />
      </service>
</deployment>
 
Is there a way that when the TestService is published no "wsdl" is appended at the start of
each node.
 
   <?xml version="1.0" encoding="UTF-8" ?> 
 <http://localhost:8080/axis/services/TestService?wsdl#> - <wsdl:definitions targetNamespace="http://localhost:8080/axis/services/TestService"
xmlns="http://schemas.xmlsoap.org/wsdl/" xmlns:apachesoap="http://xml.apache.org/xml-soap"
xmlns:impl="http://localhost:8080/axis/services/TestService" xmlns:intf="http://localhost:8080/axis/services/TestService"
xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/" xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
xmlns:wsdlsoap="http://schemas.xmlsoap.org/wsdl/soap/" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <wsdl:types /> 
  <wsdl:message name="getTestMessageRequest" /> 
 <http://localhost:8080/axis/services/TestService?wsdl#> - <wsdl:message name="getTestMessageResponse">
  <wsdl:part name="getTestMessageReturn" type="xsd:string" /> 
  </wsdl:message>
 <http://localhost:8080/axis/services/TestService?wsdl#> - <wsdl:portType name="Testing">
 <http://localhost:8080/axis/services/TestService?wsdl#> - <wsdl:operation name="getTestMessage">
  <wsdl:input message="impl:getTestMessageRequest" name="getTestMessageRequest" /> 
  <wsdl:output message="impl:getTestMessageResponse" name="getTestMessageResponse" />

  </wsdl:operation>
  </wsdl:portType>
 <http://localhost:8080/axis/services/TestService?wsdl#> - <wsdl:binding name="TestServiceSoapBinding"
type="impl:Testing">
  <wsdlsoap:binding style="rpc" transport="http://schemas.xmlsoap.org/soap/http" />

 <http://localhost:8080/axis/services/TestService?wsdl#> - <wsdl:operation name="getTestMessage">
  <wsdlsoap:operation soapAction="" /> 
 <http://localhost:8080/axis/services/TestService?wsdl#> - <wsdl:input name="getTestMessageRequest">
  <wsdlsoap:body encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" namespace="http://localhost:8080/axis/services/TestService"
use="encoded" /> 
  </wsdl:input>
 <http://localhost:8080/axis/services/TestService?wsdl#> - <wsdl:output name="getTestMessageResponse">
  <wsdlsoap:body encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" namespace="http://localhost:8080/axis/services/TestService"
use="encoded" /> 
  </wsdl:output>
  </wsdl:operation>
  </wsdl:binding>
 <http://localhost:8080/axis/services/TestService?wsdl#> - <wsdl:service name="TestingService">
 <http://localhost:8080/axis/services/TestService?wsdl#> - <wsdl:port binding="impl:TestServiceSoapBinding"
name="TestService">
  <wsdlsoap:address location="http://localhost:8080/axis/services/TestService" /> 
  </wsdl:port>
  </wsdl:service>
  </wsdl:definitions>

 
thanks
 
abhijat
 

Mime
View raw message