axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Ross <...@missioncriticalit.com>
Subject redeployment of web-service class files problem.
Date Thu, 10 Jul 2003 11:56:51 GMT
Hi,

I seem to be having a problem where if I redeploy a service, the
web-service still uses the old versions of the class files and returns
the old answer.  The only way I can get the new class files is to
restart Tomcat.

I'm trying to interactively develop a web-service using Axis 1.1
deployed in Tomcat 4.1.24 running on windows XP.

I deploy the web service so:
    >javac ws/IntelligentForm/*.java

    >copy ws\IntelligentForm\*.class c:\tomcat41\webapps\axis\WEB-INF\classes\ws\IntelligentForm
    ws\IntelligentForm\Forms.class
    ws\IntelligentForm\IntelligentForm.class
    ws\IntelligentForm\IntelligentFormService.class
    ws\IntelligentForm\IntelligentFormServiceLocator.class
    ws\IntelligentForm\IntelligentFormSOAPBindingImpl.class
    ws\IntelligentForm\IntelligentFormSOAPBindingStub.class
            6 file(s) copied.

    >cd ws/IntelligentForm

    >java org.apache.axis.client.AdminClient deploy.wsdd
    Processing file deploy.wsdd
    <Admin>Done processing</Admin>
    
I then develop the service some more, undeploy the service so

    >del c:\tomcat41\webapps\axis\WEB-INF\classes\ws\IntelligentForm\*.class

    >cd ws/IntelligentForm

    >java org.apache.axis.client.AdminClient undeploy.wsdd
    Processing file undeploy.wsdd
    <Admin>Done processing</Admin>

and then redeploy the service following the steps above for deploying
the service, but when I access the service I get the same result as the
old version of the code.  If I restart Tomcat then I get the new result.

Can anyone help?

Regards,
Peter

Mime
View raw message