axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anne Thomas Manes" <a...@manes.net>
Subject Re: Problem with AXIS 1.1 (Possible Bug)
Date Tue, 08 Jul 2003 21:31:55 GMT
Perhaps you can tell us what problems occur in Axis 1.1?

I see a number of problems with the WSDL, so perhaps the error was with Axis
1.0:

The binding specifies style='document' and use='literal', but the soap:body
<input> and <output> elements specify encodingStyle and namespace
attributes, neither of which should be present in a document/literal
binding.
<wsdl:input>

<wsdlsoap:body use="literal"
encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
namespace="http://servicefinder.ws.apsolve.com"/>

</wsdl:input>

Also the fault message <part> elements should reference an element rather
than a type.

Anne

----- Original Message -----
From: <santosh.joshi@bt.com>
To: <axis-user@ws.apache.org>
Sent: Tuesday, July 08, 2003 6:49 AM
Subject: RE: Problem with AXIS 1.1 (Possible Bug)


> All,
>
> The following wsdl attached to this message, works fine with wsdl2java
> shipped with AXIS 1.0 but does not work with AXIS 1.1.
>
> Probably exemplifying it will expose the problem, to experts on this list.
>
> Hope for an answer.
>
> Regards,
>
> Santosh
>
>
>
>
>
>
> -----Original Message-----
> From: santosh.joshi@bt.com [mailto:santosh.joshi@bt.com]
> Sent: Monday, July 07, 2003 9:07 AM
> To: axis-user@ws.apache.org
> Subject: Problem with AXIS 1.1 (Possible Bug)
>
>
> AXIS expert users,
>
> We were using AXIS 1.0 happily, until the next stable release of 1.1 came
> along. But the wsdl2java part seems to have been broken.
>
> I can run the 1.0 wsdl2java successfully on a wsdl (which imports a couple
> of Schema files, which define the data structures, which the wsdl uses).
>
> But it gives the following errors on 1.1
>
> java.io.IOException: ERROR: Missing <soap:fault> element inFault
> "SystemFault" in operation "SystemFault", in binding find
>         at
>
org.apache.axis.wsdl.symbolTable.SymbolTable.faultsFromSOAPFault(SymbolTable
> .java:2023)
>         at
> org.apache.axis.wsdl.symbolTable.SymbolTable.populateBindings(SymbolTable.
ja
> va:1801)
>         at
>
org.apache.axis.wsdl.symbolTable.SymbolTable.populate(SymbolTable.java:577)
>         at
> org.apache.axis.wsdl.symbolTable.SymbolTable.add(SymbolTable.java:421)
>         at
>
org.apache.axis.wsdl.symbolTable.SymbolTable.populate(SymbolTable.java:408)
>         at
>
org.apache.axis.wsdl.symbolTable.SymbolTable.populate(SymbolTable.java:393)
>         at
org.apache.axis.wsdl.gen.Parser$WSDLRunnable.run(Parser.java:245)
>         at java.lang.Thread.run(Thread.java:479)
>
> Any pointers to the solution, very welcome.
>
> Regards,
>
> Santosh
>
> Santosh Joshi
>
>
>


Mime
View raw message