axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Poulsen <jpoul...@metamatrix.com>
Subject RE: Unsubscription
Date Wed, 11 Jun 2003 19:08:50 GMT
the address is 

<mailto:axis-user-unsubscribe@ws.apache.org>

is this what you used?

-----Original Message-----
From: bin [mailto:binz@juke.biz]
Sent: Wednesday, June 11, 2003 4:25 PM
To: axis-user@ws.apache.org
Cc: steve.wood@informavores.com
Subject: Unsubscription


Has anybody been able to successfully un-subscribed from this mailing 
list?
I get a confirmation email from the mailing list that "unsubscribed" me, 
but the emails keep coming in.

Thanks.



On Wed, 11 Jun 2003, Sam Khan wrote:

> Hi Steve,
> 
> I'm having a similiar problem and so far havent had any luck with
solutions from the user group ( my error is listed below ). The web service
itself runs successfully, the problem occurs when trying to generate WSDL
using '?wsdl' in the URL. I'm pretty sure that it is a configuration problem
- I just dont know what it is that I need to change in the configuration. 
> There is a way for the wsdl to be returned if you have already created it
( apparently the  'correct' way to create services is to write the WSDL
first - check out the URL for more info ). However, I've tried it, but that
also doesnt work! I agree, this thing is an object lession in frustration!
> 
> Thanks,
> Sam 
> 
> 
> 
>
http://www.fawcette.com/javapro/2003_02/online/WSDL_kjones_02_27_03/default_
pf.asp
> 
> 
> 
> /------------------------ ERROR -------------------------/
> 
> Fault - The AXIS engine could not find a target service to invoke!
targetService is null 
> AxisFault
>  faultCode: {http://xml.apache.org/axis/}Server.NoService
>  faultString: The AXIS engine could not find a target service to invoke!
targetService is null
>  faultActor: null
>  faultDetail: 
> 	stackTrace: AxisFault
>  faultCode: {http://xml.apache.org/axis/}Server.NoService
>  faultString: The AXIS engine could not find a target service to invoke!
targetService is null
>  faultActor: null
>  faultDetail: 
> 
> The AXIS engine could not find a target service to invoke!  targetService
is null
> 	at
org.apache.axis.server.AxisServer.generateWSDL(AxisServer.java:482)
> 	at
org.apache.axis.transport.http.AxisServlet.doGet(AxisServlet.java:277)
> 	at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
> 	at
org.apache.axis.transport.http.AxisServletBase.service(AxisServletBase.java:
335)
> 	at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
> 
> 
> /--------------------------SNIP ---------------------------------/
> -----Original Message-----
> From: Steve Wood - Informavores [mailto:steve.wood@informavores.com]
> Sent: Wednesday, June 11, 2003 3:14 AM
> To: axis-user@ws.apache.org
> Subject: NullPointerException when calling ?WSDL
> 
> 
> Hi,
> 
> I'm having trouble with AXIS when generating the WSDL document:
> 
> AXIS error
> Sorry, something seems to have gone wrong... here are the details:
> 
> Fault - ; nested exception is:
> java.lang.NullPointerException
> 
> AxisFault
>  faultCode:
{http://schemas.xmlsoap.org/soap/envelope/}Server.userException
>  faultSubcode:
>  faultString: java.lang.NullPointerException
>  faultActor:
>  faultNode:
>  faultDetail:
> 
> I've tested the code on my machine and everything works fine so I'm
tending
> to think it's a configuration problem.  Has anyone got any ideas what
might
> be causing this to happen?
> 
> If I call the service without the ?WSDL, I get the:
> 
> FireflyDesignSubmissionSoap
> Hi there, this is an AXIS service!
> Perhaps there will be a form for invoking the service here...
> 
> Any help is greatly appreciated as I'm beginning to lose the will to live
> with this one.
> 
> Cheers,
> 
> Steve
> 
> 

Mime
View raw message