axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher Mihaly" <cmih...@hotmail.com>
Subject 302 Error on OS-X Addendum
Date Mon, 28 Apr 2003 21:24:48 GMT
   So, with some more research, I am getting 302 errors on OS-X and not on 
Windows, IRIX or Linux.   I was able to turn debugging on, and things looks 
the same until it gets to the HTTPSender.   Att his point, on the Mac, it 
does a POST http://present:8000/bc_web... and on Linux, it strips off the 
protocol, host and port and just gives bc_web...   I have no idea why this 
is different.   I include axis in my library so that code should be exactly 
the same.  The java on OS-X is Apple's supplied 1.3.1 and on our other 
platforms, it is from Sun and is 1.3.1_01.

  Any ideas?  I am still clueless why OS-X has this problema and not the 
other platforms?


On OS-X:
4337 [main] DEBUG org.apache.axis.i18n.ProjectResourceBundle  - 
org.apache.axis.i18n.resource::handleGetObject(xmlSent00)
4341 [main] DEBUG org.apache.axis.transport.http.HTTPSender  - XML sent:
4343 [main] DEBUG org.apache.axis.transport.http.HTTPSender  - 
---------------------------------------------------
4346 [main] DEBUG org.apache.axis.transport.http.HTTPSender  - POST 
http://present:8000/bc_webservice/services/BeanCount HTTP/1.0


On Linux:
2251 [main] DEBUG org.apache.axis.i18n.ProjectResourceBundle  - 
org.apache.axis.i18n.resource::handleGetObject(xmlSent00)
2251 [main] DEBUG org.apache.axis.transport.http.HTTPSender  - XML sent:
2253 [main] DEBUG org.apache.axis.transport.http.HTTPSender  - 
---------------------------------------------------
2253 [main] DEBUG org.apache.axis.transport.http.HTTPSender  - POST 
/bc_webservice/services/BeanCount HTTP/1.0

Content-Type: text/xml; charset=utf-8


_________________________________________________________________
The new MSN 8: advanced junk mail protection and 2 months FREE*  
http://join.msn.com/?page=features/junkmail


Mime
View raw message