axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Larry" <larryhyt...@myway.com>
Subject Problem with jws
Date Wed, 19 Mar 2003 13:10:28 GMT

If I run "AdminService" or "Version", two of the web services installed by default, they work
fine.  If I try to run any .jws service, like "EchoHeaders" they fail.

If I just call http://localhost:8080/axis/EchoHeaders.jws
I get a screen that says:
There is a Web Service here
Click to see the WSDL
But if I try:
http://192.168.201.225:8080/axis/EchoHeaders.jws?wsdl
I get:
Fault - ; nested exception is: 
	java.io.FileNotFoundException: /var/tomcat4/webapps/axis/WEB-INF/jwsClasses/EchoHeaders.java
(Permission denied)
AxisFault
 faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.userException
 faultSubcode: 
 faultString: java.io.FileNotFoundException: /var/tomcat4/webapps/axis/WEB-INF/jwsClasses/EchoHeaders.java
(Permission denied)
 faultActor: 
 faultNode: 
 faultDetail: 

Any idea what causes the permission denied error?  The AXIS distrib did not come with a /var/tomcat4/webapps/axis/WEB-INF/jwsClasses/EchoHeaders.java
at all.  There is no jwsClasses directory under WEB-INF.  I tried adding it, but that still
resulted in the same error.




_______________________________________________
No banners. No pop-ups. No kidding.
Introducing My Way - http://www.myway.com

Mime
View raw message