axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shobha Rani Jagathpal" <shobha.jagath...@wipro.com>
Subject RE: [wsif] sample err: Cannot get Object part 'Result'
Date Wed, 08 Jan 2003 06:26:14 GMT
U can also code it.
Like 
	System.setProperty("proxySet", "true"); 
	System.getProperties().put( "http.proxyHost", "serverName" );
	System.getProperties().put( "http.proxyPort", "8080" );

Shobha 
 


> -----Original Message-----
> From: Peake, Chris [mailto:Chris.Peake@ca.com] 
> Sent: Wednesday, January 08, 2003 4:11 AM
> To: axis-user@xml.apache.org
> Subject: RE: [wsif] sample err: Cannot get Object part 'Result'
> 
> 
> I have not tried this yet, but we have an authenticating 
> proxy.  Are there properties for userid and psw which are 
> requiered in my environment.
> 
> thanks,
>  chris
> 
> -----Original Message-----
> From: Anthony Elder [mailto:ant.elder@uk.ibm.com]
> Sent: Tuesday, January 07, 2003 3:50 PM
> To: axis-user@xml.apache.org
> Subject: RE: [wsif] sample err: Cannot get Object part 'Result'
> 
> 
> 
> If you access the Internet via a proxy server you'll need to 
> set the appropriate system properties. For example:
> 
> java -Dhttp.proxyHost=proxy.somewhere.com -Dhttp.proxyPort=80 
> -Dhttp.nonProxyHosts="localhost" clients.DynamicInvoker 
> http://services.xmethods.net/soap/urn:xmethods-delayed-quotes.
> wsdl getQuote IBM
> 
> If thats not the problem you could try running with trace on 
> and post the trace log to this list. For how to use WSIF 
> trace see: 
> http://cvs.apache.org/viewcvs.cgi/*checkout*/xml-axis-wsif/jav
> a/doc/trace.htm
> 
> 
> 
>        ...ant
> 
> Anthony Elder
> ant.elder@uk.ibm.com
> Web Services Development
> IBM UK Laboratories,  Hursley Park
> (+44) 01962 818320, x248320, MP208.
> 
> 
> "Peake, Chris" <Chris.Peake@ca.com> on 07/01/2003 21:35:46
> 
> Please respond to axis-user@xml.apache.org
> 
> To:    <axis-user@xml.apache.org>
> cc:
> Subject:    RE: [wsif] sample err: Cannot get Object part 'Result'
> 
> 
> 
> 
> I am  using the classpath.bat as suggested.
> Which  should be using the *.jars in in xerces2 dir I think,  right?
> 
> --
> G:\wsif-2.0rc1>classpath 
> build\lib\wsif.jar;build\lib\wsif-j2c.jar;build\classes;build\
> samples;build\test
> s;lib\soaprmi11\soaprmi11.jar;lib\saaj\saaj_1_1.jar;lib\jaxrpc
> \jaxrpc_1_1.jar;li
> b\commons_logging\commons-logging.jar;lib\commons_discovery\co
> mmons-discovery.ja
> r;lib\axis\servlet22.jar;lib\axis\axis_1_0.jar;lib\axis\axis_1
> _0-ant.jar;lib\apa
> che_soap\apache_soap_2_3_1.jar;lib\jms_api\jms_1_1.jar;lib\xer
> ces2\xmlParserAPIs
> _2_2_1.jar;lib\xerces2\xercesImpl_2_2_1.jar;lib\log4j\log4j-1.
> 2.4.jar;lib\wsdl4j
> \wsdl4j-20021124.jar;lib\wsdl4j\qname-from-wsdl4j-20021124.jar
> ;lib\junit\junit-3
> .8.1.jar;
> 
> As a  test, I movided the bat and placed my normal xerces 
> 1.4.4 version ahead of  this parser, but with the same results.
> 
> This  is not a priority for me.  I just wanted to try it out. 
> But if  you can think of something, I'll try it.
> 
> Maybe  turning on logging?
> How?
> 
> thanks,
>  chris
> -----Original Message-----
> From: Nirmal Mukhi  [mailto:nmukhi@us.ibm.com]
> Sent: Tuesday, January 07, 2003 3:09  PM
> To: axis-user@xml.apache.org
> Subject: RE: [wsif] sample  err: Cannot get Object part 'Result'
> 
> 
> 
> Hello Chris,
> 
> That is unlikely - the service WSDL in this case has a SOAP 
> binding  that uses HTTP as the transport, so firewalls 
> probbaly aren't the problem. I'm now thinking it might be an 
> XML parsing issue. What parser do you use? Also,  did you set 
> up the classpath using the classpath script provided with 
> WSIF?  That way you won't pick up unnecessary JAR files that 
> might be in your local  classpath that might interfere...
> 
> Nirmal.
> 
> 
>                                                               
>             
>         "Peake, Chris"                                        
>             
>         <Chris.Peake@ca.co                    To:             
>             
>         m>                            
> <axis-user@xml.apache.org>          
>                                               cc:             
>             
>         01/07/2003 03:26                       Subject:       
>  RE: [wsif] 
>         PM                            sample err:  Cannot get 
> Object part 
>         Please respond to             'Result'                
>             
>         axis-user                                             
>             
>                                                               
>             
>                                                               
>             
> 
> 
> 
> 
> I tried it again but with same results.
> Could it be a firewall situation on my  side?
> 
> chris
> -----Original  Message-----
> From: Nirmal Mukhi  [mailto:nmukhi@us.ibm.com]
> Sent: Tuesday, January 07, 2003 1:07  PM
> To: axis-user@xml.apache.org
> Subject: Re: [wsif] sample  err: Cannot get Object part 'Result'
> 
> 
> Hello Chris,
> 
> I just ran the sample using the exact command line arguments 
> you  provided and it worked ok. Could you try it again (the 
> remote service hosted  on XMethods might have been down)? If 
> it still fails, let us know what build/version of WSIF you are using.
> 
> Thanks,
> Nirmal.
> 
>                                                               
>              
>            "Peake, Chris"                                     
>              
>            <Chris.Peake@ca.com>                   To:         
>              
>                                            
> <axis-user@xml.apache.org>      
>            01/07/2003 11:09 AM                     cc:        
>              
>            Please respond to                      Subject:    
>      [wsif]  
>            axis-user                       sample err: Cannot 
> get Object   
>                                            part  'Result'     
>              
>                                                               
>              
> 
> 
> 
> 
> 
> Trying to get familiar with WSIF.
> I just tried to do run the simplesoap  example and I get the 
> following error. Cannot get Object part 'Result'
> 
> As the attached shows, classpath seems to be  correct.
> Didn't find  this in history email.
> Any ideas?
> thanks.
> 
> G:\wsif-2.0rc1>java clients.DynamicInvoker 
> samples/simplesoap/StockquoteSOAP.wsd
> l getQuote CA
> Reading WSDL document from  'samples/simplesoap/StockquoteSOAP.wsdl'
> Preparing WSIF dynamic invocation
> - WSIF0006W: Multiple WSIFProvider found  supporting the same 
> namespace URI 'http ://schemas.xmlsoap.org/wsdl/soap/'. Found 
> ('org.apache.wsif.providers.soap.apach
> eaxis.WSIFDynamicProvider_ApacheAxis,
> org.apache.wsif.providers.soap.apachesoap.
> WSIFDynamicProvider_ApacheSOAP')
> - WSIF0007I: Using WSIFProvider 
> 'org.apache.wsif.providers.soap.apacheaxis.WSIFD
> ynamicProvider_ApacheAxis' for namespaceURI 
> http://schemas.xmlsoap.org/wsdl/soa
> p/'
> Executing operation 
> getQuote
> Exception in thread "main"  org.apache.wsif.WSIFException: 
> Cannot get Object part 'Result'. No parts are set on the  message
>        at 
> org.apache.wsif.base.WSIFDefaultMessage.handleNoPartsException(Unknow
> n Source)
>       at  
> org.apache.wsif.base.WSIFDefaultMessage.getObjectPart(Unknown
> Source)
> 
>         at  clients.DynamicInvoker.invokeMethod(Unknown Source)
> 
> thanks,
> chris
> 
> 
> 
> 
> 
> 
> 

Mime
View raw message