axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benjamin Tomasini <btomas...@neteverything.com>
Subject Re: Bug/Wierdness in reading config file after class update
Date Mon, 20 Jan 2003 21:46:51 GMT
I have run into this before.  Usually it is a permissions problem
writing to server-config.wsdd.

I solved it by simply modifying the file directly, rather than running
the AdminClient.

Ben

On Mon, 2003-01-20 at 16:39, Mark Mueller wrote:
> Any chance there are some unprintable characters in
> the WSDD file?
> 
> > java.lang.Exception: Invalid
> > WSDD element 'deployment' (wanted 'deployment')
> 
> would make me suspicious.
> 
> 
> --- Sean Leach <sleach@netlojix.com> wrote:
> > Environment: Resin 2.1.5 on Linux w/ JDK 1.4 w/ Axis
> > 1.0
> > 
> > I am experiencing a wierdness when I recompile a
> > class file that is being
> > published as aa web service (it actually happens on
> > any reload, i.e. if I
> > modify the web.xml file and the webapp is reloaded)
> > 
> > Everything is working fine, i.e. I can see the
> > service in the Axis Admin,
> > and I can call the methods no problems via a test
> > client.  But if I
> > recompile a file, or modify the web.xml file etc.,
> > then I get the following
> > error whenever I try and request any Axis service
> > (admin, list deployments,
> > call method on my class):
> > 
> > 500 Servlet Exception
> > org.apache.axis.InternalException:
> > org.apache.axis.ConfigurationException:
> > org.apache.axis.deployment.wsdd.WSDDException:
> > java.lang.Exception: Invalid
> > WSDD element 'deployment' (wanted 'deployment')
> > java.lang.Exception: Invalid WSDD element
> > 'deployment' (wanted 'deployment')
> > 	at
> >
> org.apache.axis.ConfigurationException.<init>(ConfigurationException.java:89
> > )
> > 	at
> >
> org.apache.axis.deployment.wsdd.WSDDException.<init>(WSDDException.java:72)
> > 	at
> >
> org.apache.axis.deployment.wsdd.WSDDElement.validateCandidateElement(WSDDEle
> > ment.java:117)
> > 	at
> >
> org.apache.axis.deployment.wsdd.WSDDElement.<init>(WSDDElement.java:97)
> > 	at
> >
> org.apache.axis.deployment.wsdd.WSDDDeployment.<init>(WSDDDeployment.java:21
> > 9)
> > 	at
> >
> org.apache.axis.deployment.wsdd.WSDDDocument.<init>(WSDDDocument.java:107)
> > 	at
> >
> org.apache.axis.configuration.FileProvider.configureEngine(FileProvider.java
> > :210)
> > 	at
> > org.apache.axis.AxisEngine.init(AxisEngine.java:188)
> > 	at
> >
> org.apache.axis.AxisEngine.<init>(AxisEngine.java:173)
> > 	at
> >
> org.apache.axis.server.AxisServer.<init>(AxisServer.java:127)
> > 	at
> >
> org.apache.axis.server.DefaultAxisServerFactory.createServer(DefaultAxisServ
> > erFactory.java:152)
> > 	at
> >
> org.apache.axis.server.DefaultAxisServerFactory.getServer(DefaultAxisServerF
> > actory.java:116)
> > 	at
> >
> org.apache.axis.server.AxisServer.getServer(AxisServer.java:112)
> > 	at
> >
> org.apache.axis.transport.http.AxisServletBase.getEngine(AxisServletBase.jav
> > a:221)
> > 	at
> >
> org.apache.axis.transport.http.AxisServletBase.getEngine(AxisServletBase.jav
> > a:187)
> > 	at
> >
> org.apache.axis.transport.http.AxisServlet.doGet(AxisServlet.java:218)
> > 	at
> >
> javax.servlet.http.HttpServlet.service(HttpServlet.java:126)
> > 	at
> >
> org.apache.axis.transport.http.AxisServletBase.service(AxisServletBase.java:
> > 335)
> > 	at
> >
> javax.servlet.http.HttpServlet.service(HttpServlet.java:103)
> > 	at
> >
> com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:9
> > 6)
> > 	at
> >
> com.caucho.server.http.Invocation.service(Invocation.java:312)
> > 	at
> >
> com.caucho.server.http.CacheInvocation.service(CacheInvocation.java:135)
> > 	at
> >
> com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:221)
> > 	at
> >
> com.caucho.server.http.HttpRequest.handleConnection(HttpRequest.java:163)
> > 	at
> >
> com.caucho.server.TcpConnection.run(TcpConnection.java:137)
> > 	at java.lang.Thread.run(Thread.java:536)
> > 
> > 
> > If I delete the WEB-INF/server-config.wsdd, and
> > re-deploy my application, it
> > works fine (until I do one of the items above, then
> > I have to start over).
> > As you can see, this slows development quite a bit
> > :)  I don't ever touch
> > the server-config.wsdd, and it looks like valid
> > XML...
> > 
> > Anyone have a suggestion?
> > 
> > Thanks,
> > Sean
> > 
> 
> 
> __________________________________________________
> Do you Yahoo!?
> Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
> http://mailplus.yahoo.com



Mime
View raw message