axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sascha Kulawik" <sas...@kulawik.de>
Subject RE: Problems serializing german umlauts
Date Sun, 08 Dec 2002 17:48:22 GMT
Ive still this problem with the serialization. 
Is there anybody out there with the same problems ?!

> -----Original Message-----
> From: Sascha Kulawik [mailto:sascha@kulawik.de] 
> Sent: Thursday, December 05, 2002 12:58 AM
> To: axis-user@xml.apache.org
> Subject: Problems serializing german umlauts
> 
> 
> Hello,
> 
> I'm using 1.0 to generate the Stub Code for the Client 
> classes, 1.1beta for using it at the server and at the 
> client. With TCPMon I've seen, that german umlauts inside a 
> serialized XML-String (who is been sended as a string to the 
> remote method) are encoded like  & # 2 5 2 ; (without 
> spaces). If I'm looking inside the Database, I've seen, that 
> this umlaut wasn't been correct deserialized and wrong saved 
> inside the Database. On the server I'm using Axis 1.1beta 
> with an deployed WSDD file, accessing Stateless Session 
> Beans. It is a little bit amaizing, if I change the values in 
> the database, I will get the correct umlaut on the client. I 
> think, it could be a problem, that the stub-code was created 
> using the 1.0 version of axis - but as mentioned by me 
> earlier on another posting today, the 1.1 version creates 
> instead of "SessionBeanName" classes named like 
> "SessionBeanName_Port". Does anybody has a suggesion for this 
> problem ?
> 
> Regards,
> 
> Sascha
> 
> 


Mime
View raw message