axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Barry Lulas <Barry.Lu...@BristolWest.com>
Subject Error using Eclipse Tomcat plugin
Date Wed, 06 Nov 2002 15:49:25 GMT
When I try to start Tomcat using the Eclipse plugin so I can debug by Axis
web service, I get the following exception:

ERROR reading C:\Tools\tomcat\conf\server.xml
At Line 18 /Server/Listener/
className=org.apache.catalina.mbeans.ServerLifecycleListener debug=0 

Catalina.start: java.lang.ClassNotFoundException:
org.apache.catalina.mbeans.ServerLifecycleListener
java.lang.ClassNotFoundException:
org.apache.catalina.mbeans.ServerLifecycleListener
	at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:183)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:294)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:281)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:250)
	at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:310)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Class.java:115)
	at
org.apache.catalina.util.xml.ObjectCreate.start(XmlMapper.java:616)
	at
org.apache.catalina.util.xml.XmlMapper.matchStart(XmlMapper.java:412)
	at
org.apache.catalina.util.xml.XmlMapper.startElement(XmlMapper.java:91)
	at
org.xml.sax.helpers.XMLReaderAdapter.startElement(XMLReaderAdapter.java:333)
	at org.apache.crimson.parser.Parser2.maybeElement(Parser2.java:1490)
	at org.apache.crimson.parser.Parser2.content(Parser2.java:1779)
	at org.apache.crimson.parser.Parser2.maybeElement(Parser2.java:1507)
	at org.apache.crimson.parser.Parser2.parseInternal(Parser2.java:500)
	at org.apache.crimson.parser.Parser2.parse(Parser2.java:305)
	at
org.apache.crimson.parser.XMLReaderImpl.parse(XMLReaderImpl.java:442)
	at
org.xml.sax.helpers.XMLReaderAdapter.parse(XMLReaderAdapter.java:223)
	at javax.xml.parsers.SAXParser.parse(SAXParser.java:362)
	at javax.xml.parsers.SAXParser.parse(SAXParser.java:301)
	at
org.apache.catalina.util.xml.XmlMapper.readXml(XmlMapper.java:228)
	at org.apache.catalina.startup.Catalina.start(Catalina.java:725)
	at org.apache.catalina.startup.Catalina.execute(Catalina.java:681)
	at org.apache.catalina.startup.Catalina.process(Catalina.java:179)
	at java.lang.reflect.Method.invoke(Native Method)
	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:243)

Anybody have any ideas why this is happening?  Here is my plugin
configuration in Eclipse:

Version 4.1.x (I'm using 4.1.12)
Tomcat home: C:\Tools\tomcat
Configuration file: C:\Tools\tomcat\conf\server.xml

JVM Settings:

JRE: J2SDK 1.3
No other parameters are specified!

Thanks to anyone who can help!

Mime
View raw message