axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vidyanand Murunikkara" <Vidyan...@infravio.com>
Subject RE: axis 1.0 does not deploy
Date Wed, 06 Nov 2002 19:44:00 GMT
Calvin 

Try extracting the server-config.wsdd in axis.jar and placing it in
/WEB-INF.

Vidyanand.

-----Original Message-----
From: Calvin Smith [mailto:calvinrsmith@hotmail.com]
Sent: Wednesday, November 06, 2002 11:37 AM
To: axis-user@xml.apache.org
Subject: axis 1.0 does not deploy


I have so far been unable to get axis to work.
When I downloaded the 1.0 version of axis I found the axis webapp and 
deployed that to tomcat and went through the verify process, and fixed
it so 
it's happy.  But then when I tried to run a webservice I got:
- Problem with servlet engine config file: /WEB-INF/server-config.wsdd

searching my download I only find this file under
xml-axis-10\samples\jms 
why is this file not included in the download?

Trying to fix it I created a file the file under /WEB-INF and removed
the 
two services (since I'm not trying to get the jms service to work) so
now my 
file deployed file looks like:
<?xml version="1.0" encoding="UTF-8"?>
<deployment xmlns="http://xml.apache.org/axis/wsdd/"
            xmlns:java="http://xml.apache.org/axis/wsdd/providers/java">
</deployment>

again I tried to view the sample by opening my browser and going to the 
site: http://127.0.0.1:8080/axis/EchoHeaders.jws

doing so give me no error on standard out but for the webpage I get:
AXIS error
No service is available at this URL

Instead of the nice 'please use soap' that the users guide talks about.

I'm thinking my /WEB-INF/server-config.wsdd file is wrong.  Can someone 
please post what this file should be and then add it to the download?

Thanks in advance for your advice.


_________________________________________________________________
Add photos to your e-mail with MSN 8. Get 2 months FREE*. 
http://join.msn.com/?page=features/featuredemail


Mime
View raw message