axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bahman Kalali" <bkal...@csg.uwaterloo.ca>
Subject Re: migrating from apache-soap (unable to generate WSDL)
Date Sun, 03 Nov 2002 19:11:26 GMT
I had similar problem in deploying my service and viwing  its WSDL file on
the view page . I found that problem was related to deployment of service.
For example, if you simply change a java extension of a file to .jws and
there are some compiling errors in the java file, then you will not see
anything on the view page.

Further, there are some limitation in deploying a service using .jws
methods.

You can find more information about this in

http://xml.apache.org/axis/

--Bahman

----- Original Message -----
From: "Guntur N. Sarwohadi" <guntur_52@ugm.ac.id>
To: <axis-user@xml.apache.org>
Sent: Sunday, November 03, 2002 12:49 PM
Subject: RE: migrating from apache-soap (unable to generate WSDL)


This is weird... I swear I had a blank page in my first attempt
generating WSDL with that code of mine. It was like a total nothing.
Blank. I even remember trying to "view page source" and recall finding a
simple html which describes a white-blank-page (big thanks anyway,
Antonio.. :):)).. but suddenly, as I tried Antonio's suggestion, it just
simply worked!.. without me modifying ANYTHING, either my code or
anything. :/ (wonder-wonder-wonder)...

O.K.... anyway, as I explained earlier, I have a serializer custom-made
to encompass my need to handle a particular complex type.. the wsdl from
axis under the element "wsdl:types" had subelements as the following:

<schema targetNamespace="http://localhost:8080/axis/serverFTUGM.jws"
xmlns="http://www.w3.org/2001/XMLSchema">
<import namespace="http://schemas.xmlsoap.org/soap/encoding/" />
<complexType name="ArrayOf_apachesoap_Map">
<complexContent>
<restriction base="soapenc:Array">
<attribute ref="soapenc:arrayType" wsdl:arrayType="apachesoap:Map[]" />
</restriction>
</complexContent>
</complexType>
<element name="ArrayOf_apachesoap_Map" nillable="true"
type="impl:ArrayOf_apachesoap_Map" />
</schema>

I was a little puzzled to wonder how could axis come up with a
"apachesoap:Map[]" while the code hadn't mention anything about it. If I
were to use apachesoap, should that wsdl:arrayType refer to the
custom-made serializer (i.e. CustomMadeSerializer)?

Cheers,
[g]

-----Original Message-----
From: António Manuel Nogueira Santos [mailto:ansantos@fe.up.pt]
Sent: Thursday, October 31, 2002 7:24 PM
To: axis-user@xml.apache.org
Subject: Re: migrating from apache-soap (unable to generate WSDL)



> Hi people :)
>
> I have developed a webservice app using apache-soap and just trying to
> tweak abit in axis just to generate the WSDL for my service. I
deployed
> it with a .jws file, had tomcat already running, but somehow when I
> access http://localhost:8080/axis/myService.jws?wsdl, nothing shows..
> a.k.a. just plain white blank page. Did I miss anything here now?
>

Use "View Page Source". ;)

All the best,

ASantos



Mime
View raw message