axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Howard" <chow...@boxlake.com>
Subject RE: javax/servlet/ServletContext not defined
Date Fri, 11 Oct 2002 17:53:46 GMT
Great that fixes that problem.  I can now deploy services and run the
example stock service.  Only 1 issue left that I know of.  When I go to
http://127.0.0.1:8080/axis/servlet/AdminServlet I get a 404 error.  Now I do
have axis.jar in my classpath so I'm quite sure that isn't the problem and I
have restarted tomcat recently.  Any ideas.

Thanks
-Chris

-----Original Message-----
From: dmyaho [mailto:dmyaho@vol.vnn.vn]
Sent: Friday, October 11, 2002 1:39 PM
To: axis-user@xml.apache.org
Subject: Re: javax/servlet/ServletContext not defined


do you have servlet.jar in your classpath?

----- Original Message -----
From: "Chris Howard" <choward@boxlake.com>
To: "'Axis-User" <axis-user@xml.apache.org>
Sent: Friday, October 11, 2002 10:06 AM
Subject: javax/servlet/ServletContext not defined


> I'm getting the following error when ever I try to run anything..
>
> Exception in thread "main" java.lang.NoClassDefFoundError:
> javax/servlet/Servlet
> Context
>         at java.lang.Class.getDeclaredMethods0(Native Method)
>         at java.lang.Class.privateGetDeclaredMethods(Class.java:1627)
>         at java.lang.Class.getMethod0(Class.java:1746)
>         at java.lang.Class.getDeclaredMethod(Class.java:1233)
>         at
> org.apache.commons.discovery.tools.ClassUtils.findPublicStaticMethod(
> ClassUtils.java:112)
>         at
> org.apache.axis.configuration.EngineConfigurationFactoryFinder.newFac
> tory(EngineConfigurationFactoryFinder.java:214)
>         at
> org.apache.axis.configuration.EngineConfigurationFactoryFinder.access
> $300(EngineConfigurationFactoryFinder.java:92)
>         at
> org.apache.axis.configuration.EngineConfigurationFactoryFinder$1.run(
> EngineConfigurationFactoryFinder.java:179)
>         at java.security.AccessController.doPrivileged(Native Method)
>         at
> org.apache.axis.configuration.EngineConfigurationFactoryFinder.newFac
> tory(EngineConfigurationFactoryFinder.java:148)
>         at
> org.apache.axis.configuration.EngineConfigurationFactoryFinder.newFac
> tory(EngineConfigurationFactoryFinder.java:204)
>         at org.apache.axis.client.Service.<init>(Service.java:111)
>         at org.apache.axis.client.AdminClient.<init>(AdminClient.java:123)
>         at org.apache.axis.client.AdminClient.main(AdminClient.java:339)
>
> After poking around I don't see a class by this name.  I assume I'm
missing
> a directory on my classpath, that has been most of my problems so far
> throughout this install.  This particular error occured when I was
> attempting to deploy the stock quote example.
>
> Thanks,
>
> Chris Howard
> Web Application Developer
> http://www.boxlake.com
> 1.866.box.lake
> choward@boxlake.com
>
>
>



Mime
View raw message