axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jagadeesan,Sivakumar" <sivakumar.jagadee...@dhs.state.tx.us>
Subject RE: Complete ant script?
Date Mon, 28 Oct 2002 20:34:06 GMT
<!-- 
    Author : Sivakumar Jagadeesan
 Date   : 10/23/2002
 Project: Interest Calculator Web Service
 Email  : sivajag@hotmail.com <mailto:sivajag@hotmail.com> 
 
 Pre-Condition : Before using this build file you need to change some of the

     Hardcoded values
 
 Please send the comments / feedback. It will be appreciated
-->
 
<?xml version="1.0"?>
 
<!-- =======================================================================
-->
<!-- Interest Calculator build file
-->
<!-- =======================================================================
-->
 
<project name="InterestCalculatorService" default=" " basedir=".">
 
<!-- =======================================================================
-->
<!-- Properties
-->
<!-- =======================================================================
-->
 <property name="application.name" value = "InterestCalculator" />
 <property name="axis.home.dir" location="C:\Axis\bin" />
 <property name="axis.dist.dir" location="${axis.home.dir}/lib" />
 <property name="axis.dir" location="${lib.dir}/xml-axis" />
 <property name="tomcat.home.dir" location="C:\Tomcat4.0" />
 <property name="tomcat.lib.dir" location="${tomcat.home.dir}/common/lib" />
 <property name="tomcat.dist.dir"
location="${tomcat.home.dir}/webapps/axis/WEB-INF/classes" />
 <property name="xercesxalan.dir" location="${lib.dir}/xercesxalan" />
 <property name="build.dir" location="build" />
 <property name="build.classes.dir" location="${build.dir}/classes" />
 <property name="build.services.classes.dir"
location="${build.dir}/services/classes" />
 <property name="fetched.dir" location="${build.dir}/fetched" />
 <property name="generated.dir" location="${build.dir}/generated" />
 <property environment="env"/>
 
<!-- =======================================================================
-->
<!-- ClassPath
-->
<!-- =======================================================================
-->
 
 <path id="axis.classpath">
  <fileset dir="${axis.dist.dir}"> 
   <include name="**/*.jar"/>
  </fileset>
  <fileset dir="${tomcat.lib.dir}">
   <include name="**/*.jar"/>
  </fileset>
  
 </path>
 
<!-- =======================================================================
-->
<!-- Server Side
-->
<!-- =======================================================================
-->
 
 <!-- Makes the initial directories -->
 <target name="init">
  <mkdir dir="${fetched.dir}" />
  <mkdir dir="${generated.dir}" />
  <mkdir dir="${build.classes.dir}" /> 
  <mkdir dir="${build.classes.dir}/${application.name}" />
  <condition property="offline">
   <not>
   <http url="${endpoint}" />
   </not>
  </condition>
  <fail unless="env.CATALINA_HOME">Tomcat not found</fail>
  <mkdir dir="${tomcat.dist.dir}" /> 
 </target>
 
 <!-- Deletes the build directory in the work directory -->
 <target name="clean">
  <delete dir="${build.dir}"/>
 </target>
 
 <!-- Deletes the files in the application directory of the webapp directory
-->
 <target name="clean.tomcat">
  <delete dir="${tomcat.axis.dir}/${application.name}"/>
 </target>
 
 <!-- Compiles the java files -->
 <target name="compile.service" depends="init"> 
  <javac
   srcdir="soap"
   destdir="${build.classes.dir}"
   debuglevel="lines,vars,source"
   debug="true"
   includeAntRuntime="false"
  >
  </javac>
 </target>
 
 <!-- Copies the server files from the work directory to Webapp -->
 <target name="deploy" depends="compile.service">
   <copy todir="${tomcat.dist.dir}">
      <fileset dir="${build.classes.dir}"/>
   </copy>
 </target>
 
 <!-- Registers the service -->
 <target name="register" depends="deploy" >
  <java
   classname="org.apache.axis.client.AdminClient"
   fork="true"
   failonerror="true"
  >
   <arg value="C:\Work\WebServices\InterestCalculator\wsdd\deploy.wsdd"/> 
   <classpath>
    <path refid="axis.classpath"/>
   </classpath>
  </java>
 </target>
 
 <!-- Unregisters a service -->
 <target name="unregister" >
  <java
   classname="org.apache.axis.client.AdminClient"
   fork="true"
   failonerror="true"
  >
   <arg value="C:\Work\WebServices\InterestCalculator\wsdd\undeploy.wsdd"/> 
   <classpath>
    <path refid="axis.classpath"/>
   </classpath>
  </java>
 </target>
 
<!-- =======================================================================
-->
<!-- Client Side
-->
<!-- =======================================================================
-->
 
 <!-- Compiles the client -->
 <target name="compile.client" depends="init"> 
  <javac
   srcdir="src"
   destdir="${build.classes.dir}/${application.name}"
   debuglevel="lines,vars,source"
   debug="true"
   includeAntRuntime="false"
  >
   <classpath>
    <path refid="axis.classpath"/>
    <pathelement location="${build.classes.dir}"/>
   </classpath>
  </javac>
 </target>
 
 <!-- Copies the wsdd file to the build directory so that wsdd will be in
the same directory as class files -->
 <target name="deploy.client" depends="register.client">
   <copy todir="${build.classes.dir}/${application.name}">
      <fileset dir="C:\Work\WebServices\InterestCalculator\src\wsdd\"
includes="*.wsdd"/>
   </copy>
 </target>
 
 
 <!-- Generates the client side wsdd file -->
 <target name="register.client" depends="compile.client" >
  <java
   classname="org.apache.axis.utils.Admin"
   fork="true"
   failonerror="true"
  >
   <arg value="client"/> 
   <arg
value="C:\Work\WebServices\InterestCalculator\src\wsdd\deploy_client.wsdd"/>

   <classpath>
    <path refid="axis.classpath"/>
   </classpath>
  </java>
 </target>
 
 <!-- Runs the client after deploying the client-->
 <target name="run"  depends="deploy.client" >
  <java
   classname="TestService"
   fork="true"
   failonerror="true"
  >
   <arg value="10000"/>
   <arg value="5.5"/>
   <arg value="15"/>
   <classpath>
    <path refid="axis.classpath"/>
    <pathelement location="${build.classes.dir}"/>
    <pathelement location="${build.classes.dir}/${application.name}"/>
   </classpath>
  </java>
 </target>
 
 <!-- Runs the client -->
 <target name="run.only"  >
  <java
   classname="TestService"
   fork="true"
   failonerror="true"
  >
   <arg value="10000"/>
   <arg value="5.5"/>
   <arg value="5"/>
   <classpath>
    <path refid="axis.classpath"/>
    <pathelement location="${build.classes.dir}"/>
    <pathelement location="${build.classes.dir}/${application.name}"/>
   </classpath>
  </java>
 </target>
 
</project>
 
 

-----Original Message-----
From: Barry Lulas [mailto:Barry.Lulas@BristolWest.com]
Sent: Monday, October 28, 2002 2:20 PM
To: 'axis-user@xml.apache.org'
Subject: Complete ant script?


Does anyone have a complete ant script for building a web service with Axis?
There are small snippets out there, but if anyone has a complete script I
would love to see it.
 
Barry

-----Original Message-----
From: RKumar [mailto:rkumar@digev.com]
Sent: Monday, October 28, 2002 3:16 PM
To: axis-user@xml.apache.org
Subject: RE: Problem running Axis on Tomcat 4.1.12...


I have the name as Axis , but still it doesn't work.
Kumar

-----Original Message-----
From: Barry Lulas [mailto:Barry.Lulas@BristolWest.com]
Sent: Monday, October 28, 2002 12:06 PM
To: 'axis-user@xml.apache.org'
Subject: RE: Problem running Axis on Tomcat 4.1.12...


I found my own problem.  In the Axis documentation it states that you need
to create a subdirectory under the Tomcat webapps directory and you can name
it anything you want.  I named my subdirectory myws, rather than axis, and
this is what caused the exception.  I renamed it back to axis and everything
works fine.  Is this hard coded somewhere?  All my commands pointed to the
correct subdirectory...

-----Original Message-----
From: Barry Lulas [mailto:Barry.Lulas@BristolWest.com]
Sent: Monday, October 28, 2002 2:33 PM
To: 'axis-user@xml.apache.org'
Subject: Problem running Axis on Tomcat 4.1.12...



I think I have a problem with the way I have installed Axis on Tomcat
4.1.12.  All the rest of the validations checkout, but when I try to run the
AdminServlet I get the following Tomcat exception.  I checked the Tomcat
installation and the AdminServlet is NOT in the listed directory, but I
can't find it anywhere in the Axis installation.  Am I missing some
installation steps here?

HTTP Status 404 - /axis/servlet/AdminServlet 

type Status report 
message /axis/servlet/AdminServlet 
description The requested resource (/axis/servlet/AdminServlet) is not
available. 

Apache Tomcat/4.1.12 


Mime
View raw message