axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emma Johansson <Emma.Johans...@su.eip.ericsson.se>
Subject what might be wrong? Please help me.
Date Mon, 21 Oct 2002 11:08:34 GMT
Hi!

When browsing to http://150.132.6.212:8080 jakarta tomcats homepage is
viewing and I'm able to execute some examples from that page. Even thogh
everything is extreamly slow.

When browsing to http://150.132.6.212:8080/soap the soap homepage pops
up (after several minutes) But when I'm trying to list the deployed list
an error message tells me
-------------------------
HTTP Status 500 -

type Exception report

message

description The server encountered an
internal error () that prevented it from fulfilling
this request.

exception

org.apache.jasper.JasperException: Unable to compile class for JSP

An error occurred at line: 4 in the jsp file: /admin/list.jsp

Generated servlet error:
    [javac] Compiling 1 source file

/home/loke/ejoemma/tomcat/work/Standalone/localhost/soap/admin/list_jsp.java:8:
package org.apache.soap does not exist
import org.apache.soap.Constants;
                       ^
/home/loke/ejoemma/tomcat/work/Standalone/localhost/soap/admin/list_jsp.java:9:
package org.apache.soap.server does not exist
import org.apache.soap.server.*;
^
.....
......
......
------------------------------------

The same thing is with apache axis. I can browse to the homepage
(...:8080/axis) but when trying to click 'Validate' or 'View' error
pages appears instead of the correct pages.

--------------------------------------
HTTP Status 500 -

type Exception report

message

description The server encountered an internal error () that prevented
it from fulfilling this request.

exception

org.apache.jasper.JasperException: Cannot inherit from final class
        at
org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:248)

        at
org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:289)

        at
org.apache.jasper.servlet.JspServlet.service(JspServlet.java:240)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
....
...
...
--------------------------------------


This is my .cshrc file (classpath):
Have I missed some or must I change the location of some of the files?
----------------------------------------------------------------
source /usr/local/lib/Cshrc
setenv PATH
/usr/local/j2sdk1.4.0/bin:/home/loke/ejoemma/tomcat/bin:${PATH}

setenv CLASSPATH .:
/usr/local/j2sdk1.4.0/lib:.:
/usr/local/j2sdk1.4.0:
/usr/local/j2sdk1.4.0/bin:
/home/loke/ejoemma/tomcat/common/lib/servlet.jar:
/home/loke/ejoemma/tomcat/common/lib/mail.jar:
/home/loke/ejoemma/tomcat/common/lib/activation.jar:
/home/loke/ejoemma/soap-2_3_1/lib/soap.jar:
/home/loke/ejoemma/soap-2_3_1:
/home/loke/ejoemma/tomcat:
/home/loke/ejoemma/xml-axis-10:
/home/loke/ejoemma/tomcat/webapps/axis/WEB-INF/lib/axis.jar:
/home/loke/ejoemma/tomcat/webapps/axis/WEB-INF/lib/commons-discovery.jar:

/home/loke/ejoemma/tomcat/webapps/axis/WEB-INF/lib/commons-logging.jar:
/home/loke/ejoemma/tomcat/webapps/axis/WEB-INF/lib/jaxrpc.jar:
/home/loke/ejoemma/tomcat/webapps/axis/WEB-INF/lib/saaj.jar:
/home/loke/ejoemma/tomcat/webapps/axis/WEB-INF/lib/log4j-1.2.4.jar:
/home/loke/ejoemma/tomcat/webapps/axis/WEB-INF/lib/wsdl4j.jar:
/home/loke/ejoemma/tomcat/webapps/axis/WEB-INF/lib/xercesImpl.jar:
/home/loke/ejoemma/tomcat/webapps/axis/WEB-INF/lib/xmlParserAPIs.jar

-------------------------------------------------------------------

Does anyone know what I should do to make (specially) axis to work?

/Emma


Mime
View raw message