axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin O'Neill" <ke...@rocketred.com.au>
Subject Re: How to make Axis work in WSAD
Date Tue, 29 Oct 2002 03:07:48 GMT
On Tue, 2002-10-29 at 09:33, David.Pool@kp.org wrote:
> I have successfully installed Axis into Tomcat 4.1.10. I can bring up the 
> AdminServlet OK, the validation page looks OK, and I successfully ran the 
> Calculator.jws/CalClient  example program.
> 
> Now I'm trying to install Axis into WSAD 4.0 (Websphere Studio Application 
> Developer). The validation page looks OK, but the AdminServlet give me a 
> 500 error:
> 
> Error Message: org.w3c.dom.Node: method getLocalName()Ljava/lang/String; 
> not found
> Error Code: 500
> Target Servlet: null
> Error Stack: 
> java.lang.NoSuchMethodError: org.w3c.dom.Node: method 
> getLocalName()Ljava/lang/String; not found 
>      at 
> org.apache.axis.deployment.wsdd.WSDDDocument.<init>(WSDDDocument.java:104) 
> 
> etc.

Looks like a problem with the dom apis loaded into your environment. I
don't use WSAD so I can't tell you how to fix it but start by checking
for jars that export org.w3c.dom.Node in your WSAD classpath and replace
them with more recent versions.

If you using jdk 1.4 you should also ensure that the correct version of
xerces is in your jre lib/ext.


> The calculator service does not work either in WSAD with the same error 
> message.
> 
> Is there anything I have to do especially for the WSAD environment to get 
> it to work? Any clues would be greatly appreciated.
> 
> Thanks,
> Dave

-k.

-- 
If you don't test then your code is only a collection of bugs which 
apparently behave like a working program. 

Website: http://www.rocketred.com.au/blogs/kevin/


Mime
View raw message