axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Geza.Sz...@nokia.com>
Subject RE: Trailing characters around <SOAPENV> when using HTPP/1.1 in request
Date Tue, 03 Sep 2002 09:47:52 GMT
This is due to chunked encoding. See RFC for HTTP1.1.


-----Original Message-----
From: ext Tonny Bruckers [mailto:antoine.bruckers@chello.be]
Sent: 03. September 2002 11:40
To: axis-user@xml.apache.org
Subject: Trailing characters around <SOAPENV> when using HTPP/1.1 in request


Hello,

while testing my webservice I get the following problem: when I send a request to the webservice
using HTTP/1.1 I get characters outside the soapenv tags ?  Can this be resolved while still
using HTPP/1.1 ?

--- Request ---

POST /axis/services/urn:BodemattestService HTTP/1.1
Content-Type: text/xml

Host: 192.168.0.3

SOAPAction: ""

Content-Length: 1050


<?xml version="1.0" encoding="UTF-8" standalone="no"?><SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance" xmlns:xsd="http://www.w3.org/1999/XMLSchema"><SOAP-ENV:Body><ns1:requestBodemattest
xmlns:ns1="urn:BodemattestService" SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"><arg0
xsi:type="xsd:int">144</arg0><arg1 xsi:type="xsd:string">test9</arg1><arg2
xsi:type="xsd:int">25014</arg2><arg3 xsi:type="xsd:int">880</arg3><arg4
xsi:type="xsd:string">A</arg4><arg5 xsi:type="xsd:int">0</arg5><arg6
xsi:type="xsd:string">&apos;&apos;</arg6><arg7 xsi:type="xsd:int">0</arg7><arg8
xsi:type="xsd:string">R DE L ERMITAGE</arg8><arg9 xsi:type="xsd:dateTime">2002-08-22T18:23:57.850Z</arg9><arg10
xsi:type="xsd:int">1</arg10><arg11 xsi:type="xsd:int">1</arg11><arg12
xsi:type="xsd:int">1</arg12><arg13 xsi:type="xsd:int">0</arg13><arg14
xsi:type="xsd:int">0</arg14><arg15 xsi:type="xsd:int">0</arg15></ns1:requestBodemattest></SOAP-ENV:Body></SOAP-ENV:Envelope>

--- Response ---
HTTP/1.1 200 OK

Content-Type: text/xml; charset=utf-8

Date: Tue, 03 Sep 2002 09:39:38 GMT

Server: Apache Tomcat/4.0.4 (HTTP/1.1 Connector)

Transfer-Encoding: chunked



38b

<?xml version="1.0" encoding="UTF-8"?>
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
 <soapenv:Body>
  <ns1:requestBodemattestResponse soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
xmlns:ns1="urn:BodemattestService">
   <requestBodemattestReturn href="#id0"/>
  </ns1:requestBodemattestResponse>
  <multiRef id="id0" soapenc:root="0" soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
xsi:type="ns2:Result" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/" xmlns:ns2="urn:ResultService">
   <resultcode xsi:type="xsd:int">1</resultcode>
   <resulttext xsi:type="xsd:string">CRT-nummer (144) is niet bekend bij OVAM.</resulttext>
   <resultsaldo xsi:type="xsd:float">0.0</resultsaldo>
  </multiRef>
 </soapenv:Body>
</soapenv:Envelope>

0

Mime
View raw message