axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Weicheng Peng" <weich...@voxa.com>
Subject Re: SimpleServer vs. Tomcat 4.0.x
Date Fri, 27 Sep 2002 17:09:11 GMT
You didn't deploy your web service in Simple Server.
Weicheng

----- Original Message -----
From: "Jung, Eric (Contractor)" <ejung@russellmellon.com>
To: <axis-user@xml.apache.org>
Sent: Friday, September 27, 2002 10:01 AM
Subject: SimpleServer vs. Tomcat 4.0.x


> Hi group,
> When I deploy my service "Schedules" in Tomcat 4.0.4 and go to
> http://localhost:8080/services/Schedules?wsdl the wsdl returns as
expected.
> Same thing when I call methods on my Tomcat-hosted service from a client;
> everything works fine.
>
> However, when I run the service using Axis SimpleServer, all calls return:
>
> AxisFault faultCode: {http://xml.apache.org/axis/}Server.NoService
> faultString: The AXIS engine could not find a target service to invoke!
> targetService is null faultActor: null faultDetail: The AXIS engine could
> not find a target service to invoke! targetService is null at
> org.apache.axis.server.AxisServer.generateWSDL(AxisServer.java:484) at
>
org.apache.axis.transport.http.SimpleAxisWorker.run(SimpleAxisWorker.java:32
> 3) at
>
org.apache.axis.transport.http.SimpleAxisServer.run(SimpleAxisServer.java:16
> 7) at
>
org.apache.axis.transport.http.SimpleAxisServer.start(SimpleAxisServer.java:
> 206) at
>
org.apache.axis.transport.http.SimpleAxisServer.start(SimpleAxisServer.java:
> 214) at
>
org.apache.axis.transport.http.SimpleAxisServer.main(SimpleAxisServer.java:2
> 77
>
> My targetService is not null. Even typing
> http://localhost:8080/services/Schedules?wsdl in a browser returns this
> fault.
>
> I tried using Axis nightly build from 9-27-02 (today) and Beta 3 release,
> but I get the same results with both. This used to work!
>
> Any ideas?
>
> TYIA,
> Eric H. Jung
>
>


Mime
View raw message