axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jung, Eric (Contractor)" <ej...@russellmellon.com>
Subject RE: problem after deploying new service
Date Thu, 15 Aug 2002 16:10:24 GMT
Hi Tom,

Yes, it certainly seems to be a classloader issue. I had tried your
suggestion already without any luck. (How can my jar be in tomcat's
common/lib and STILL not be found?!?!)

I think your suggestions are good, and I will try them again just in case I
missed something.

Thank you!

Eric H. Jung
p.s. yes, TaskManagerImpl is in package com.russellmellon.scheduler

-----Original Message-----
From: Tom Myers [mailto:tommyers@dreamscape.com]
Sent: Thursday, August 15, 2002 11:22 AM
To: axis-user@xml.apache.org
Cc: 'axis-user@xml.apache.org'
Subject: RE: problem after deploying new service


Eric Jung gets 
>>   java.lang.ClassNotFoundException:
>> com/russellmellon/scheduler/TaskManagerImpl...
>> 
>> I put my class, TaskManagerImpl.class, in:
>> 
>> %CATALINA_HOME%/webapps/axis/WEB-INF/classes/com/russellmellon/scheduler

I presume that your TaskManagerImpl class is defined within, umm,
  package com.russellmellon.scheduler;
right? 
It is possible to get a ClassNotFoundException from something which is
"on the classpath" because the classpath is not really linear; you're
dealing with a hierarchy of class loaders, forming a tree with visibility
going up but not down or sideways. If this might be your problem, I would 
  (a) make a copy of your whole tomcat setup,
  (b) go into that classes directory and
  jar -cf scheduler.jar com/russellmellon/scheduler/*.class
  (c) move the scheduler.jar into tomcat's common/lib directory
  (d) restart tomcat, try again, see what if anything is still NotFound
and if necessary move everything into jars in common/lib. This is not 
exactly ideal, but it should make everything visible to everything else.
(For war-file distribution, you may then need to pick apart the
relationships and figure out what extra things need to go in your axis
WEB-INF/lib.) 
 But maybe it's not that at all.

Tom Myers

Mime
View raw message