axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Taras Shkvarchuk <Tar...@grandcentral.com>
Subject RE: Custom serializers don't appear to work
Date Fri, 12 Jul 2002 02:19:54 GMT
They did work for a nightly build a few weeks before beta3 was released.
Now I am using beta3 and I don't see the null pointer exception you see, but
I do get mapping not found.
java.lang.Exception: !! No Deserializer for
{http://grandcentral.com/schemas/delivery/v1}delivery
	at
org.apache.axis.message.MessageElement.getValueAsType(MessageElement.java:52
2)
Something did break in beta3...

> -----Original Message-----
> From: Dunn, Scott [mailto:SDunn@sonusnet.com]
> Sent: Thursday, July 11, 2002 5:41 PM
> To: 'axis-user@xml.apache.org'
> Subject: Custom serializers don't appear to work
> 
> 
> This was posted against beta 2 but I never saw any response - 
> do custom
> serializers work in beta 3? I have deployed a customer 
> serializer and get
> the following when I try to access my service:
> 
>        stackTrace: java.lang.NullPointerException
>        at
> org.apache.axis.description.ServiceDesc.createOperationForMeth
> od(ServiceDesc
> .java:794)
> It appears that TypeMapping doesn't get set, presumably from 
> WSDDService
> during initialisation.
> 
> Can anyone confirm whether or not this is a known bug or am I doing
> something wrong in my deployment descriptor (extract below)? The same
> descriptor but using the standard BeanSerializer works fine.
> 
>       <typeMapping
>         xmlns:ns="http://www.sonusnet.com/model"
>         qname="ns:ManagedEntityKey"
>         type="java:com.sonus.model.ManagedEntityKey"
>         serializer="com.sonus.service.ManagedEntitySerializerFactory"
>         
> deserializer="org.apache.axis.encoding.ser.BeanDeserializerFactory"
>         encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
>       />
> Thanks,
> 
> Scott.
> 

Mime
View raw message