axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Heitzso <heit...@bellsouth.net>
Subject Re: JDK 1.4 Java aint finding javax.*
Date Wed, 24 Jul 2002 01:55:51 GMT
Haven't tried happyaxis.jsp.  When it was crashing it was
crashing on the way up and axis failed thereafter.

I kludged (my perspective) a fix by copying the key jars
over to jakarta-tomcat-4.0.4/common/lib:
	current stable xerces 2 (2 jars)
	axis/lib jars less the logging jars
(logging jars were actually where the conflict was with
the other project in our branch).

This seems to be working under linux when compiled/run
under blackdown 1.3.1 or compiled jikes 1.15 and run
sun 1.4.1_01.  Haven't tried my windows setups yet.

BTW, I do have all key jars (full axis lib plus xerces 2)
in WEB-INF/lib and should be picked up via tomcat 4.0.4
but something messy was happening.

Heitzso


On Tue, 2002-07-23 at 16:28, Steve Loughran wrote:
> 
> ----- Original Message ----- 
> From: "Heitzso" <heitzso@bellsouth.net>
> To: <axis-user@xml.apache.org>
> Sent: Tuesday, July 23, 2002 1:05 PM
> Subject: RE: JDK 1.4 Java aint finding javax.*
> 
> 
> > I want to second that comment re Sun revisiting the ClassLoader thing.
> > I've spent some 8 hours thrashing this, my env is still broken, and
> > I thought I knew what I was doing.
> > 
> > Our policy is to _not_ assume we can put jar files in a servlet 
> > container lib directory (since we won't own the box when app is
> > distributed) and another of our projects conflicts with the 
> > parser setup required by axis.  So, not using java.endorsed.dirs,
> > etc.  I'm running tomcat 4.0.4 so trying to put everything
> > in WEB-INF/lib but that's not working either.
> > 
> 
> what is happyaxis.jsp saying?
> 



Mime
View raw message