axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Owens <dow...@synxis.com>
Subject RE: Removing xsi types from xml.
Date Tue, 09 Jul 2002 19:25:36 GMT
Matthias,

Yes, that is exactly what I am trying to do.  I have actually gotten the
server side not to send the xsi types (by setting sendXsiTypes="false"
as a parameter in the global configuration) but the client doesn't seem
to know how to deal with it.  I have set the same parameter in the
client-config file.

Any help is greatly appreciated.

Thanks!

|)ave
dowens@synxis.com

On Tue, 2002-07-09 at 12:40, Wimmer, Matthias wrote:
> David:
> 
> I copied you a small part of the stuff that my system is exchanging. It's a
> call by SOAP-RPC. As you can see, in the upper part there are no xsi:type
> attributes. If this is what you are looking for, I can send you the code.
> 
> Matthias Wimmer
> 
> 
> <SOAP-ENV:Envelope
> xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" 
>             xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
>             xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
>  <SOAP-ENV:Body>
>      <Insurance Name="bim">
>         <Benefits>
>             <Copay>ENTER</Copay>
>             <Select>
>                 <Type>DEDUCTIBLE</Type>
>                 <Period>HOUR</Period>
>             </Select>
>             <Enter>
>                 <Amount>100</Amount>
>                 <Period>DAY</Period>
>             </Enter>
>             <Coinsurance>101</Coinsurance>
>         </Benefits>
>      </Insurance>
> 
>      <ns1:retrieveBenefitsResponse 
>  
> SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/" 
>            xmlns:ns1="InsuranceWebService">
>                <retrieveBenefitsReturn
> xsi:type="xsd:string">ok</retrieveBenefitsReturn>
>      </ns1:retrieveBenefitsResponse>
>  </SOAP-ENV:Body>
> </SOAP-ENV:Envelope>
> 
> > -----Original Message-----
> > From: David Owens [mailto:dowens@synxis.com]
> > Sent: Tuesday, July 09, 2002 12:20 PM
> > To: axis-user@xml.apache.org
> > Subject: Removing xsi types from xml.
> > 
> > 
> > Hi all!
> > 
> > Right now I am sending xml from axis to axis and I am trying to
> > decrease the xml size.  I changed the configuration on both
> > the client and server to NOT send xsi types.  It worked, in that
> > the server stopped sending the xsi type, but it blew up on
> > the client.
> > 
> > Has anyone else used this feature axis to axis?
> > Does anyone know if it is supposed to work?
> > 
> > Thanks in Advance!
> > 
> > |)ave
> > dowens@synxis.com
> > 
-- 
And in my spare time, I think I'll write some code.


Mime
View raw message