axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joseph Carew <jca...@kana.com>
Subject Axis on WebLogic Server 6.1 sp2
Date Fri, 21 Jun 2002 19:06:03 GMT
I am attempting to run the web app created by the dist ant target on
WebLogic 6.1 sp2.  When the server tries to deploy Axis it fails with the
following error (snipped stack trace):
####<Jun 21, 2002 2:23:48 PM EDT> <Info> <HTTP> <JCAREW1> <myserver>
<main>
<system> <> <101060> <[myserver] Loading "axis" from directory:
".\config\mydomain\applications\axis"> 
####<Jun 21, 2002 2:23:49 PM EDT> <Info> <HTTP> <JCAREW1> <myserver>
<main>
<system> <> <101031> <[WebAppServletContext(713078,axis,/axis)] extracting
classfiles to
C:\beasp2\wlserver6.1\.\config\mydomain\applications\axis\WEB-INF\_tmp_war_m
yserver_myserver_axis:> 
####<Jun 21, 2002 2:23:49 PM EDT> <Debug> <HTTP> <JCAREW1> <myserver>
<main>
<system> <> <101158> <Exception thrown while loading axis:
java.lang.StringIndexOutOfBoundsException: String index out of range: -1> 
java.lang.StringIndexOutOfBoundsException: String index out of range: -1
 at java.lang.String.substring(String.java:1525)
 at
weblogic.servlet.internal.WebAppHelper.resolveManifestName(WebAppHelper.java
:469)
 at
weblogic.servlet.internal.WebAppHelper.extractClassFiles(WebAppHelper.java:2
34)
 at
weblogic.servlet.internal.WebAppServletContext.extractClassFiles(WebAppServl
etContext.java:3407)
 at
weblogic.servlet.internal.WebAppServletContext.setDocroot(WebAppServletConte
xt.java:3376)
 at
weblogic.servlet.internal.WebAppServletContext.init(WebAppServletContext.jav
a:862)
 at
weblogic.servlet.internal.WebAppServletContext.<init>(WebAppServletContext.j
ava:815)
 at weblogic.servlet.internal.HttpServer.loadWebApp(HttpServer.java:428)
 at weblogic.j2ee.WebAppComponent.deploy(WebAppComponent.java:74)
 at weblogic.j2ee.Application.addComponent(Application.java:163)
 at weblogic.j2ee.J2EEService.addDeployment(J2EEService.java:117)
 at
weblogic.management.mbeans.custom.DeploymentTarget.addDeployment(DeploymentT
arget.java:329)
 at
weblogic.management.mbeans.custom.DeploymentTarget.addDeployment(DeploymentT
arget.java:144)
 at
weblogic.management.mbeans.custom.WebServer.addWebDeployment(WebServer.java:
76)
 at java.lang.reflect.Method.invoke(Native Method)

 
Has anyone else seen this issue?  BEA gave me a patch that didn't seem to do
any good.

Mime
View raw message