axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carl Trusiak <catman412...@yahoo.com>
Subject Re: Need Help, Unable to run any Axis Samples
Date Mon, 03 Jun 2002 11:48:42 GMT
I had something similar on Tomcat 4.0.3.  In the logs
it was reporting a security exception on a class in
the tt-bytecode.jar.  I extracted all the files and
rebuilt the jar.  Everything worked after that.

Carl

--- Sybase Employee <username@sybase.com> wrote:
> I've installed Tomcat 4.0.4 beta 3 and axis beta 2. 
> My tomcat seems to
> be ok, and I was able to start the axis server.  But
> I'm unable to
> deploy services or invoke any of the samples.  I get
> the following
> error:
> 
> C:\>java org.apache.axis.client.AdminClient
> -lhttp://localhost:80/axis/services/
> AdminService deploy.wsdd
> - Exception:
> org.apache.axis.ConfigurationException:
> java.lang.NullPointerException
>         at
>
org.apache.axis.configuration.FileProvider.configureEngine(Unknown
> S
> urce)
>         at org.apache.axis.AxisEngine.init(Unknown
> Source)
>         at org.apache.axis.AxisEngine.<init>(Unknown
> Source)
>         at
> org.apache.axis.client.AxisClient.<init>(Unknown
> Source)
>         at
> org.apache.axis.client.Service.getAxisClient(Unknown
> Source)
>         at
> org.apache.axis.client.Service.<init>(Unknown
> Source)
>         at
> org.apache.axis.client.AdminClient.<init>(Unknown
> Source)
>         at
> org.apache.axis.client.AdminClient.main(Unknown
> Source)
> - Exception:
> org.apache.axis.InternalException:
> org.apache.axis.ConfigurationException: java
> lang.NullPointerException
>         at org.apache.axis.AxisEngine.init(Unknown
> Source)
>         at org.apache.axis.AxisEngine.<init>(Unknown
> Source)
>         at
> org.apache.axis.client.AxisClient.<init>(Unknown
> Source)
>         at
> org.apache.axis.client.Service.getAxisClient(Unknown
> Source)
>         at
> org.apache.axis.client.Service.<init>(Unknown
> Source)
>         at
> org.apache.axis.client.AdminClient.<init>(Unknown
> Source)
>         at
> org.apache.axis.client.AdminClient.main(Unknown
> Source)
> 
> I believe I have the necessary jar file in the
> correct location and my
> classpath set, but just in case they are included
> below:
> 
> C:\>echo %CLASSPATH%
>
.;c:\myjava;c:\jdk1.3.1\lib\tools.jar;c:\jdk1.3.1\lib\dt.jar;c:\Apache\Tomcat4.0
> 
>
\Xerces\xerces-1_2_0\xerces.jar;C:\Ant\jakarta-ant_1_2\lib\ant.jar;C:\Ant\jakart
> 
>
a-ant_1_2\lib\jaxp.jar;C:\Ant\jakarta-ant_1_2\lib\parser.jar;w:\esdweb\lib\testd
> 
>
river.jar;C:\jsse1.0.2\lib\jsse.jar;C:\jsse1.0.2\lib\jnet.jar;C:\jsse1.0.2\lib\j
> 
>
cert.jar;c:\Apache\Tomcat4.0\webapps\axis\WEB-INF\lib\axis.jar;c:\Apache\Tomcat4
> 
>
.0\webapps\axis\WEB-INF\lib\commons-logging.jar;c:\Apache\Tomcat4.0\webapps\axis
> 
>
\WEB-INF\lib\log4j-core.jar;c:\Apache\Tomcat4.0\webapps\axis\WEB-INF\lib\tt-byte
> 
>
code.jar;c:\Apache\Tomcat4.0\webapps\axis\WEB-INF\lib\xerces.jar;c:\Apache\Tomca
> 
>
t4.0\webapps\axis\WEB-INF\lib\wsdl4j.jar;c:\Apache\Tomcat4.0\webapps\axis\WEB-IN
> 
>
F\lib\jaxrpc.jar;c:\Apache\Tomcat4.0\webapps\axis\WEB-INF\lib\clutil.jar;C:\Apac
> 
> he\xml-axis-beta2
> 
> C:\Apache\Tomcat4.0\webapps\axis\WEB-INF\lib>ls
> axis.jar             log4j-core.jar       xerces.jar
> clutil.jar           sax.jar             
> xercesImpl.jar
> commons-logging.jar  tt-bytecode.jar
> jaxrpc.jar           wsdl4j.jar
> 
> thanks,
> Marion
> 


__________________________________________________
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup
http://fifaworldcup.yahoo.com

Mime
View raw message