axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Pannier" <spann...@jacada.com>
Subject SOAP Versioning question
Date Mon, 20 May 2002 16:42:26 GMT
Hello.  The AXIS User Guide states the following in the "What's in this
release" section:

This release includes the following features:
           SOAP 1.1 compliant engine (with some SOAP 1.2 support as well)

My question is this: What does this mean as far as SOAP versioning in AXIS?
That is,
in what situations (if any) will AXIS generate a SOAP VersionMismatch
fault?  If I send a
SOAP 1.2 envelope to my AXIS server, should I expect to see a
VersionMismatch fault?

I know what the SOAP 1.2 spec says in the "Version Transition from SOAP/1.1
to SOAP
Version 1.2" section.  But I need to know exactly what AXIS supports (or
intends to support)
in this area.  Is this something that is intended to be supported, but
hasn't yet been
implemented?  (I see that Constants.java defines "URI_CURRENT_SOAP_ENV" and
"URIS_SOAP_ENV", but neither of these are used anywhere throughout the AXIS
sourcecode.)

Any info on this issue would be greatly appreciated!  Thanks in advance.



Steve Pannier
Jacada, Inc.
(763) 201-0002 Ext. 219
spannier@jacada.com
http://www.jacada.com



Mime
View raw message