axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark_Pal...@wildfire.com
Subject RE: Using Axis Beta2 in JBoss/Tomcat
Date Thu, 16 May 2002 20:28:06 GMT

When packaging my service inside of the Axis war file, it gets
automatically deployed when it gets copied into the JBoss deploy
directory.  There doesn't seem to be a way to use the AdminClient or the
wsdd file once this happens.

How do you connect to your service when you package things this way?

-Mark



                                                                                         
                               
                    thomas.cherel@ascentialso                                            
                               
                    ftware.com                      To:     axis-user@xml.apache.org     
                               
                                                    cc:                                  
                               
                    05/16/2002 01:16 PM             Subject:     RE: Using Axis Beta2 in JBoss/Tomcat
                   
                    Please respond to                                                    
                               
                    axis-user                                                            
                               
                                                                                         
                               
                                                                                         
                               




They way I have been doing so far is the following:


1) The code of my services is included in the Axis war file.
2) Nothing specific in the wsdd file or the way the AdminClient is used.


Thomas


-----Original Message-----
From: Mark_Palmer@wildfire.com [mailto:Mark_Palmer@wildfire.com]
Sent: Thursday, May 16, 2002 1:00 PM
To: axis-user@xml.apache.org
Subject: Using Axis Beta2 in JBoss/Tomcat






I have a few questions about using Axis in the JBoss environment.


When using Axis with Tomcat alone, you put all the Axis stuff in
%CATALINA_HOME%/webapps/axis.


This doesn't work when running JBoss with Tomcat.


I read in another posting that you need to create a WAR file with all the
Axis stuff and drop it into the JBoss "deploy" directory.


This works fine.


The question is:  now where do you place Axis services that you want to
deploy?  Do they still go in %CATALINA_HOME%/webapps/axis
directory?


Will there be anything different that needs to be done when running the
Axis AdminClient program to deploy the service?  Or anything different
in the WSDD deployment file?


Thanks.


-Mark








Mime
View raw message