axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carl Trusiak <catman412...@yahoo.com>
Subject RE: Using Axis Beta2 in JBoss/Tomcat
Date Fri, 17 May 2002 19:37:18 GMT
Check the log files for your server.  You are probably
going to see a class not found exception.  You need to
include an XML Parser as the installation docs tell
you.  I use Xerces personnally.


--- Mark_Palmer@wildfire.com wrote:
> 
> The following is the contents of my WAR file (it's
> called am-axis.war).  I
> would add my own .jar files in the WEB-INF/lib
> directory.
> 
>      0 Thu May 16 16:20:04 EDT 2002 META-INF/
>     48 Thu May 16 16:20:04 EDT 2002
> META-INF/MANIFEST.MF
>      0 Thu May 16 16:20:04 EDT 2002 WEB-INF/
>      0 Thu May 16 16:13:20 EDT 2002 WEB-INF/lib/
> 800632 Thu May 16 16:13:20 EDT 2002
> WEB-INF/lib/axis.jar
>  55754 Thu May 16 16:13:20 EDT 2002
> WEB-INF/lib/commons-logging.jar
>  44099 Thu May 16 16:13:20 EDT 2002
> WEB-INF/lib/jaxrpc.jar
>  78140 Thu May 16 16:13:20 EDT 2002
> WEB-INF/lib/log4j-core.jar
> 130773 Thu May 16 16:13:20 EDT 2002
> WEB-INF/lib/tt-bytecode.jar
> 143069 Thu May 16 16:13:20 EDT 2002
> WEB-INF/lib/wsdl4j.jar
>   1276 Thu May 16 16:06:54 EDT 2002 WEB-INF/web.xml
> 
> Everything in this .war file is the contents of the
> webapps/axis directory.
> 
> I don't get any errors when I deploy this file - it
> seems to work fine.  I do notice that it gets
> deployed under the name of the file "am-axis".
> Maybe I
> need to just call it "axis.war".  Or maybe I need to
> place it in a .ear file and supply an
> application.xml file?
> 
> If possible, I'd really like to be able to deploy my
> services in a separate .war or .ear file.
> 
> Anyone out there know how to do that?
> 
> -Mark
> 
> 
> 
>                                                     
>                                                     
>                
>                     thomas.cherel@ascentialso       
>                                                     
>                
>                     ftware.com                     
> To:     axis-user@xml.apache.org                    
>                 
>                                                    
> cc:                                                 
>                 
>                     05/17/2002 03:03 PM            
> Subject:     RE: Using Axis Beta2 in JBoss/Tomcat   
>                 
>                     Please respond to               
>                                                     
>                
>                     axis-user                       
>                                                     
>                
>                                                     
>                                                     
>                
>                                                     
>                                                     
>                
> 
> 
> 
> 
> Even before trying to get your service working, you
> need to make sure that
> the Axis servlet is correctly deployed.
> Something is wrong in the way you deploy it in
> JBoss/Tomcat since you can
> not even access it. Double check the structure of
> your war file and the
> content of your web.xml.
> 
> 
> For sure, with axis beta2 and the
> JBoss2.4.4/Tomcat4.0.1 I am able to
> deploy axis as a war and it is working fine.
> 
> 
> Thomas
> 
> 
> -----Original Message-----
> From: Mark_Palmer@wildfire.com
> [mailto:Mark_Palmer@wildfire.com]
> Sent: Thursday, May 16, 2002 5:31 PM
> To: axis-user@xml.apache.org
> Subject: RE: Using Axis Beta2 in JBoss/Tomcat
> 
> 
> 
> 
> 
> 
> When I try to go to that URL, I get HTTP status 500
> messages that say "no
> context configured to process this request".
> 
> 
> I placed my service ".jar" file into the WEB-INF/lib
> directory inside the
> axis.war file (which has pretty much everything from
> webapps/axis in it),
> and
> deployed this in JBoss.
> 
> 
> When I run the AdminClient, I get the same error as
> I did above.
> 
> 
> Any other ideas?
> 
> 
> Thanks.
> 
> 
> -Mark
> 
> 
> 
> 
> 
> 
> 
> 
>                     thomas.cherel@ascentialso
> 
> 
>                     ftware.com                     
> To:
> axis-user@xml.apache.org
> 
> 
>                                                    
> cc:
> 
> 
>                     05/16/2002 04:43 PM            
> Subject:     RE: Using
> Axis Beta2 in JBoss/Tomcat
> 
> 
>                     Please respond to
> 
> 
>                     axis-user
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> If you use the JBoss_Tomcat bundle, when starting
> JBoss, tomcat is also
> started.
> Dropping axis.war in the JBoss deploy directory will
> actually deploy Axis
> in the bundled Tomcat servlet engine and the Axis
> servlet is accessible
> like in a standalone Tomcat deployment (try the URL
> http://localhost:8080/axis/services, you should get
> something).
> 
> 
> 
> 
> 
> The AdminClient is talking to the Axis servlet, so
> no problem on this side
> and you submit your deploy.wsdd the same way as
> before:
> 
> 
> 
> 
> 
> % java org.apache.axis.client.AdminClient
> deploy.wsdd
> 
> 
> 
> 
> 
> 
=== message truncated ===


__________________________________________________
Do You Yahoo!?
LAUNCH - Your Yahoo! Music Experience
http://launch.yahoo.com

Mime
View raw message