axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Russell Butek" <bu...@us.ibm.com>
Subject Re: QFault problem
Date Fri, 26 Apr 2002 13:16:47 GMT
QFault no longer exists.  It looks like you're probably running with
something that hasn't been recompiled with the latest version you
downloaded.

Why does QFault no longer exist?  It extended QName, but QName is supposed
to be final (according to the JAX-RPC spec).  QFault was just being used as
a special-case QName, so all references to QFault in AXIS have been changed
to QName.

Russell Butek
butek@us.ibm.com


"Jean-Marc Taillant" <taillan2@bst.bsf.alcatel.fr> on 04/26/2002 01:46:03
AM

Please respond to axis-user@xml.apache.org

To:    <axis-user@xml.apache.org>
cc:
Subject:    QFault problem




Hi all,
I get last axis lib build from 2002/04/25 ( i got  the 2002/04/19) and when
i try to laucn my server ( all was fine before) i  get:

2002-04-26 08:39:26 - Ctx(/gis) : Exception in R(  /gis + /services +
/SessionService) -  java.lang.NoClassDefFoundError
org/apache/axis/utils/QFault
         at java.lang.Class.newInstance0(Native  Method)
        at  java.lang.Class.newInstance(Class.java:237)
         at org.apache.tomcat.facade.ServletHandler.getServlet(Unknown
Source)
        at  org.apache.tomcat.facade.ServletHandler.preInit(Unknown
Source)
        at  org.apache.tomcat.facade.ServletHandler.init(Unknown  Source)
        at  org.apache.tomcat.facade.ServletHandler.service(Unknown
Source)
        at  org.apache.tomcat.core.ContextManager.internalService(Unknown
Source)
        at  org.apache.tomcat.core.ContextManager.service(Unknown  Source)
        at
org.apache.tomcat.modules.server.Http10Interceptor.processConnection(Unknown

 Source)
        at  org.apache.tomcat.util.net.TcpWorkerThread.runIt(Unknown
Source)
        at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(Unknown
Source)
        at  java.lang.Thread.run(Thread.java:484)


This class wsn't present in gis.jar. Is it a build  error or not ?

Thanks
Jean Marc




Mime
View raw message