axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "David L. Cole" <DLC...@cmsenergy.com>
Subject Re: Axis/BEA WL 6.1 for those who have no problems
Date Thu, 28 Feb 2002 20:09:49 GMT

I am having the same problem u r Gus...something got screwed up in the
nightly build WSDL generation I think....looking into it right now.



                                                                                         
                              
                    Gus Delgado                                                          
                              
                    <gdelgado@netquo        To:     axis-user@xml.apache.org          
                                 
                    tient.com>              cc:                                       
                                 
                                            Subject:     Re: Axis/BEA WL 6.1 for those who
have no problems             
                    02/28/2002 01:49                                                     
                              
                    PM                                                                   
                              
                    Please respond                                                       
                              
                    to axis-user                                                         
                              
                                                                                         
                              
                                                                                         
                              




Thanks David I fixed that problem by getting the latest jar from cvs now
I'm getting the:
White space is required between the public identifier and the system
identifier. on the client site
and on the server side the same error Herve is getting
NullPointerException
at java.io.File.<init>(File.java:180)
...
...


-Gus
On Thu, 2002-02-28 at 10:58, David L. Cole wrote:
>
> That occurred from a ClassLoader error in the commons-logging.jar.
> I was able to get around the problem by getting the latest
> commons-loggin.jar v1.2 from axis cvs
>
>
>
>

>                     Gus Delgado

>                     <gdelgado@netquo        To:
axis-user@xml.apache.org
>                     tient.com>              cc:

>                                             Subject:     Re: Axis/BEA WL
6.1 for those who have no problems
>                     02/28/2002 10:16

>                     AM

>                     Please respond

>                     to axis-user

>

>

>
>
>
>
> I just tried that version and I keep getting an error:
>
> Servlet failed with Exception
> java.lang.ExceptionInInitializerError:
> org.apache.commons.logging.LogConfigurationException:
> org.apache.commons.logging.LogConfigurationException: No suitable Log
> constructor
>            at
>
org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactoryImpl.java:494)

>
> ...
> ..
> ...
>
> any ideas?
>
> -thanks
>
> On Thu, 2002-02-28 at 09:56, herve attia wrote:
>
> Hello David,
>
> Could you describe your approach to set Axis with BEA WL 6.1 ?
>
> Did you replace the weblogic parser :
>
> weblogic.apache.xerces.jaxp.DocumentBuilderFactoryImpl  ??
>
> Did you deploy Axis as a WAR file or just configure your DefaultWebApp
> directory ?
>
> If you could give some informations about your approach...that will help
> a lot of folks !!
>
> thanks.
>
> I gonna try nighty build 022502....and give my feeback
>
> herve
>
>
>
>
>
>
>
>
>
>
>
>
> *********************************
> Herve Attia
> Cell (650) 922-1973
> Home (650) 992-3997
> http://www.chez.com/attia/resume/
> >From: "David L. Cole"
>
> >Reply-To: axis-user@xml.apache.org
> >To: axis-user@xml.apache.org
> >Subject: Re: Axis/BEA WL 6.1 Can we indicate new location for the
> server-config.wsdd?
> >Date: Thu, 28 Feb 2002 09:39:25 -0600
> >
> >
> >I am using Weblogic 6.1 and this problem doesn't occur IF I use the
> >nightly-build as of 2/25/2002.
> >You might try that.
> >
> >Good Luck,
> >David Cole
> >
> >
> >
> >
> > "Glyn Normington"
> > > k.ibm.com> cc:
> > Subject: Re: Axis/BEA WL 6.1 Can we indicate new location for the
> > 02/28/2002 03:25 server-config.wsdd?
> > AM
> > Please respond to
> > axis-user
> >
> >
> >
> >
> >
> >
> >
> >Herve,
> >
> >Believe it or not, I think you got further, at least on the server
> side.
> >The problem you are seeing seems to be caused by an attachments
> directory
> >property not being set. If you want to keep trying, you could set a
> system
> >property axis.attachments.Directory to a suitable directory.
> >
> >Others seem to have gotten further with weblogic, so you might like to
> >search for weblogic in an axis-user archive (e.g.
> >http://marc.theaimsgroup.com/?l=axis-user&r=1&w=2) to see what they
> have
> >noticed.
> >
> >It's a pity that you seem to have hit rather unusual errors, but you're
> >testing has at least resulted in some improved diagnostics and a small
> fix
> >going into Axis, so thanks for your efforts. I hope you'll have more
> >success later....
> >
> >Glyn
> >
> >
> >
> > "herve attia"
> >
> > >
> > tmail.com> cc:
> >
> > Subject: Re: Axis/BEA WL 6.1
> >Can we indicate new location for the
> > 27/02/02 18:30 server-config.wsdd?
> >
> > Please respond
> >
> > to axis-user
> >
> >
> >
> >
> >
> >
> >I got different errors on server side 8-)
> >
> >
> > Servlet failed with Exception
> >java.lang.NullPointerException
> > at java.io.File.(File.java:180)
> > at
> >org.apache.axis.server.DefaultAxisServerFactory.getServer(Unknown
> Source)
> > at org.apache.axis.server.AxisServer.getServer(Unknown Source)
> > at org.apache.axis.transport.http.AxisServlet.getEngine(Unknown
> >Source)
> >
> >
> >
> >and client side :
> >
> >
> >$java -Daxis.ServerConfigFile=server-config.wsdd
> >org.apache.axis.client.AdminClient deploy.xml
> >- Processing file deploy.xml
> >- AxisFault: AxisFault
> > faultCode: http://xml.apache.org/axis/:Server.userException
> > faultString: org.xml.sax.SAXParseException: White space is required
> >between the
> > public identifier and the system identifier.
> > faultActor: null
> >
> >
> >
> >Enjoy weblogic-Axis !! ;-)
> >
> >
> > >From: Gus Delgado
> > >Reply-To: axis-user@xml.apache.org
> > >To: axis-user@xml.apache.org
> > >Subject: Re: Axis/BEA WL 6.1 Can we indicate new location for the
> >server-config.wsdd?
> > >Date: 27 Feb 2002 10:33:07 -0600
> > >
> > >I've tried setting up the
> > >-Daxis.ServerConfigFile=/home/mydomain/server-config.wsdd with the
> > >nightly build version from 2002/02/26 and when I try to deploy one of
> > >the examples I get a Fault error now.
> > >
> > >White space is required between the public identifier and the system
> > >identifier.
> > >
> > >I get this while trying to run the AdminClient
> > >
> > >on the server side I get an error
> > >org.apache.commons.logging.LogConfigurationException: No suitable Log
> > >constructor ???
> > >
> > >can anyone help me with either of these two problems? Thanks in
> > >advanced.
> > >
> > >-Gus
> > >
> > >On Wed, 2002-02-27 at 09:22, herve attia wrote:
> > >
> > >
> > >
> > >The problem is that this new feature exists only in some recent
> nighty
> > >build. For instance ,
> > >http://xml.apache.org/dist/axis/nightly/2002-02-26/
> > >
> > >So, you have to download it and recompile.....That doesn't guarantee
> > >Axis to be stable ?!
> > >
> > >I haven't yet tryed yet !!
> > >
> > >herve
> > >
> > >
> > >
> > >
> > >
> > >
> > >*********************************
> > >Herve Attia
> > >Cell (650) 922-1973
> > >Home (650) 992-3997
> > >http://www.chez.com/attia/resume/
> > > >From: Gus Delgado
> > > >Reply-To: axis-user@xml.apache.org
> > > >To: axis-user@xml.apache.org
> > > >Subject: Re: Axis/BEA WL 6.1 Can we indicate new location for the
> > >server-config.wsdd?
> > > >Date: 27 Feb 2002 08:11:31 -0600
> > > >
> > > >Herve,
> > > >did you ever find a solution to the FileNotFoundException
> > > >null/server-config.wsdd. I'm still getting it, when deploying it on
> > > >WebLogic 6.1. Your help is much appreciated.
> > > >
> > > >-Gus
> > > >
> > > >On Tue, 2002-02-26 at 12:14, herve attia wrote:
> > > >
> > > >Glyn,
> > > >
> > > >Sorry to bother you but I tried to set the system property as
> following
> > > >:
> > > >
> > > >This both approach doesn't work.
> > > >
> > > >Weblogic commande line :
> > > >
> > > >"%JAVA_HOME%\bin\java" -hotspot -ms64m -mx64m -classpath
> "%CLASSPATH%"
> > > >....
> > > >
> > > >"-Daxis.ServerConfigFile=E:\temp\server-config.wsdd"
> > > >
> > > >weblogic.Server
> > > >
> > > >or Axis AdminClient
> > > >
> > > >$java -Daxis.ServerConfigFile=.\server-co
> > > >nfig.wsdd org.apache.axis.client.AdminClient -p8080 deploy.xml
> > > >
> > > >
> > > >
> > > >
> > > >
> > > >
> > > >*********************************
> > > >Herve Attia
> > > >Cell (650) 922-1973
> > > >Home (650) 992-3997
> > > >http://www.chez.com/attia/resume/
> > > > >From: "Glyn Normington"
> > > > >To: "herve attia"
> > > > >Subject: Re: Axis/BEA WL 6.1 Can we indicate new location for the
> > > >server-config.wsdd?
> > > > >Date: Tue, 26 Feb 2002 15:51:09 +0000
> > > > >
> > > > >
> > > > > >I didn't find any system property "axis.ServerConfigFile"
> within
> > >the
> > > >Axis
> > > > >documentation.
> > > > >The documentation is currently incomplete.
> > > > >
> > > > >
> > > > > >Is there a way to indicate a new location for the
> > >server-config.wsdd
> > > >?
> > > > >
> > > > >
> > > > >Yes. Set the system property axis.ServerConfigFile to contain the
> > >full
> > > >path
> > > > >and name of the file.
> > > > >
> > > > >Glyn
> > > > >
> > > >
> > >
> >________________________________________________________________________
> > > >Chat with friends online, try MSN Messenger: Click Here
> > > >
> > > >--
> > > >Gus Delgado
> > > >Consultant
> > > >NetQuotient Consulting Group
> > > >e-mail: gus.delgado@netquotient.com
> > > >cell: 512-587-6986
> > > >
> > >
> >
> >________________________________________________________________________
> > >Get your FREE download of MSN Explorer at http://explorer.msn.com.
> > >
> > >--
> > >Gus Delgado
> > >Consultant
> > >NetQuotient Consulting Group
> > >e-mail: gus.delgado@netquotient.com
> > >cell: 512-587-6986
> > >
> >
> >MSN Photos is the easiest way to share and print your photos: Click
> Here
> >
> >
> >
> >
> >
> >
> >
>
> ________________________________________________________________________
> Send and receive Hotmail on your mobile device: Click Here
>
> --
> Gus Delgado
> Consultant
> NetQuotient Consulting Group
> e-mail: gus.delgado@netquotient.com
> cell:   512-587-6986
>
>
>
>
--
Gus Delgado
Consultant
NetQuotient Consulting Group
e-mail: gus.delgado@netquotient.com
cell:   512-587-6986






Mime
View raw message