axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "BEERS,NANCY (HP-NewJersey,ex2)" <nancy_be...@hp.com>
Subject RE: Bug found in wsdl2java, please read
Date Wed, 06 Feb 2002 20:21:05 GMT
I saw this bug in Beta3 recently, but it seems to be fine in the latest
snapshot.

Nancy

> -----Original Message-----
> From: Russell Butek [mailto:butek@us.ibm.com]
> Sent: Wednesday, February 06, 2002 3:19 PM
> To: axis-user@xml.apache.org
> Subject: Re: Bug found in wsdl2java, please read
> 
> 
> WSDL2Java doesn't process annotations.  They're ignored.
> 
> You'll have to show me your WSDL.  I tried plunking 
> annotations randomly
> through a test of ours and it didn't make any difference to what was
> generated.
> 
> Russell Butek
> butek@us.ibm.com
> 
> 
> obrand <obrand@yahoo.com> on 02/06/2002 01:47:52 PM
> 
> Please respond to axis-user@xml.apache.org
> 
> To:   axis <axis-user@xml.apache.org>
> cc:
> Subject:  Bug found in wsdl2java, please read
> 
> 
> 
> I have struggled for days with wsdl2java in order to have many
> complextypes generated.
> 
> If you have:
> 
> <xsd:complexType name="mytype">
>                     <xsd:annotation>
>                         <xsd:documentation>this is some
> documentation</xsd:documentation>
>                     </xsd:annotation>
> 
>                     .......
> 
> Then only one compex type (the first ??) gets generated.
> 
> I had to remove the annotation tags to have a proper generation. Does
> not make sense at all !!! I believe the release 2 of axis worked.
> 
> Olivier
> 
> 
> _________________________________________________________
> Do You Yahoo!?
> Get your free @yahoo.com address at http://mail.yahoo.com
> 
> 
> 

Mime
View raw message